Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We are using Jetty to run an Apache Solr index. We've had some queries that have grown way beyond the previously expected maximum length, and are now having issues where most queries are not returning any data because the server doesn't respond (browser says "Connection reset").

These requests are not being made through a browser, they're being made programmatically using the Apache_Solr_Service PHP library. The application is expecting queries to come in as HTTP GET requests, so simply switching to a POST will not solve this problem.

How can we increase the maximum allowed HTTP GET query length in Jetty?

Thanks!

share|improve this question
add comment

3 Answers

up vote 3 down vote accepted

http://serverfault.com/questions/56691/whats-the-maximum-url-length-in-tomcat

share|improve this answer
    
Thanks but I said Jetty, not Tomcat. I can't seem to find anywhere in Jetty's configuration files where I would put the settings you've linked to. –  Michael Moussa Apr 27 '10 at 15:12
    
headerbuffersize? –  JamesRyan Apr 27 '10 at 21:08
    
Tried it. No luck. –  Michael Moussa Apr 28 '10 at 12:44
    
We decided to ditch Jetty and switch to Tomcat. After doing so, we were able to make the changes indicated in link you provided and are no longer experiencing problems. Thanks! –  Michael Moussa May 5 '10 at 17:08
add comment

A little late to the party, but I've just come up against the same problem.

Add the following to the connectors section of jetty.xml:

<Set name="headerBufferSize">65536</Set>

This will increase the header limit from the default of 4KB to 64KB.

share|improve this answer
    
This solution worked for us. The symptom in the logs was java.io.IOException: FULL. Make sure to add the setting in whichever active addConnector section you're using. –  Tom Harrison Jr Dec 12 '13 at 20:20
add comment
<Set name="headerBufferSize">65536</Set>

is now deprecated. You can use:

<Set name="requestHeaderSize">65535</Set>

instead.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.