Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a Dell PE2950 file server running Windows 2008, hosting a DFS namespace of ~1.2 TB. This server has two Broadcom 1Gbps NICs teamed together.

When there is high traffic going to the server across the network (greater than 200 Mbps), any Windows 7 client accessing a DFS share at the time experiences severe performance problems.

For example:

  • Computer A has an AutoCAD drawing opened directly from the DFS share. Performance is normal, not causing any issues.
  • Computer B begins a file transfer, putting a 11GB file onto a different DFS namespace, on the same server
  • Computer A immediately notices lag while using AutoCAD. The cursor momentarily freezes within AutoCAD every 10 seconds or so, and any browsing of the DFS share is extremely slow.
  • Computer B completes file transfer, and performance resumes to normal for Computer A.

This is only affecting Windows 7 clients, using a variety of hardware (desktop + laptop). All of our Windows XP clients see no performance impact during the file transfer.

Things I have tried with no change:

  • Had Computer A work from an entirely different RAID array from the file transfer destination
  • Updated NIC drivers on clients and server
  • Enabled TCP offload and receive side scaling on the server NIC (previously disabled when the issue began)
  • Antivirus disabled during file transfer

I am currently having a user test applications other than AutoCAD when the file transfer occurs, and will update the question with that result.

Does anyone have any recommendations for resolution or additional troubleshooting steps?

Update: This issue appears to only affect Windows Explorer and AutoCAD. Using a separate application such as Microsoft Office or Internet Explorer (to an intranet page on the affected server) have no slow down issues.

share|improve this question
    
What is the disk access for this server? Local Raid, SAN, NAS? –  Scott Lundberg Apr 27 '10 at 16:37
    
Disk access for the DFS shares is on an MD3000 direct attached through redundant SAS cables. As mentioned above, while the file transfer was occuring on one RAID array in the MD3000, performance was impacted for a share on a second RAID array on the second controller in the MD3000. –  Jeff Miles Apr 27 '10 at 17:35
    
so if you use ms office or acad to open a file thats hosted via dfs what happens vs going directoy to the share\file –  tony roth May 28 '10 at 17:44
add comment

1 Answer

up vote 1 down vote accepted

Firstly so you understand, two 1G network cards transferring at ~220meg/sec in Windows is actually maxing out the network links. So that is the underlying issue as to why things are slow.

For your problem however, AutoCad runs temporary files onto the location where the file is opened, in this case your DFS share. You can confirm this using Process Monitor. Since access to the DFS share is slow, the temp files are slow and thus AutoCad is slow. You can configure AutoCad to keep temp files locally which we do.

Why Windows 7 see it and Windows XP doesn't is most likely down to TCP Window Scaling. XP doesn't do any while Win7 and Vista does. This MS KB talks through the steps of disabling the tuning properties, try it on one client and see if it fixes things. Moving the Temp files is probably a better option however.

share|improve this answer
    
Raising this from the dead: the temp files is a definite possibility, although for the most part we have AutoCAD configured to store files locally, although the DWL files are still stored on the server. I'm not experiencing the problem anymore as we've set up a new Server 2008 R2 file server VM and it doesn't appear to have the same problem. I'll mark this as correct since it's the most likely cause that I didn't originally consider. Also of note, the file transfers were in excess of 220 Mbps, not 220 MBps. –  Jeff Miles May 2 '12 at 17:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.