Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have been testing OWA and have found that when there is an attached file on a message it shows the "Attachments:" then the file name (but no link) and then [Open as Web Page] link. The user has to click on that which opens a new window and previews the document, then the user gets "You are currently viewing:" followed by the file name. This time the file name is a link that they can open/download. This happens for Office documents and PDF file at least.

How do I make it so users can get a direct link to the file on the original message window?

Here is a picture of what the user sees when they select a message from the inbox.

Not what I want... :(

Here is what my entire screen looks like. alt text

share|improve this question
Is this a windows 2000 server? – Campo Apr 28 '10 at 20:55
What version of Exchange/OWA are you using? How are users accessing the OWA (what browser, etc) – Holocryptic Apr 28 '10 at 20:56
I am not sure. I'm not the admin, I'm just trying to find out what's wrong so I can tell them what exactly to do to fix it. Since without that they will brush it off and do nothing. Any way to tell which version just from the OWA portal? IE 7 is the browser users are using. – jamone Apr 28 '10 at 20:58
Weird figured an older version would give you this issue. I am on 2003 and it works. The admins may have changed the way users can view/download attachments in OWA may wanna check with them. – Campo Apr 28 '10 at 21:00
"I am not sure. I'm not the admin". Then better talk to the admin, who is the one who should be asking questions on this site, not the end user. – John Gardeniers Apr 28 '10 at 21:51
up vote 0 down vote accepted

Admins must have changed the setting.

In a comment I asked Jerry to check. He asked his admins and they confirmed and fixed the problem.

share|improve this answer
This answer is practically useless to those who are trying to solve this problem. What setting? Where is it located? How do I get to it? It was a waste of my time to even click on this thread through Google. – Bobort Jul 16 '15 at 15:40

Right click on the attachment Click "Save link as"


Just tested this with a .docx

EDIT: Screenshot alt text

If that is to hard to see click here

share|improve this answer
That's what I want to do but its not an option when you are viewing the email. There is NO link to the attachment, only a link to "Open as Web Page" and from that pop up window you then get the link to the file that you can right click and "Save link as". – jamone Apr 28 '10 at 20:26
This is for .doc etc.... Emails that have an email as an attachment exhibit the characteristics you describe in your comment. I edited my post to include a screen grab of what I see. – Campo Apr 28 '10 at 20:37
I just posted a complete screen shot of my OWA site, and it looks quite different from yours. I've tried right clicking and save as but its not treating the file name as a link (like yours does). It doesn't even pop up a context menu when I right click. – jamone Apr 28 '10 at 20:54
Admins may have disabled the feature see my comment on the question – Campo Apr 28 '10 at 21:01

This was an setting set by some admin.

Why: They don't know, and until they do they won't change it back...

share|improve this answer
Glad you resolved this issue. Please be sure to mark your answer as "accepted" when you are able. – jscott Jul 23 '12 at 14:20

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.