Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have window server which shares the folder called wwwroot.

In my ubuntu that window computer is not visible.

When i press ctrl + L

and type smb://window-comp-name/wwwroot

Then it works

I tried mounting that folder using

sudo mount smb://SERVER/wwwroot /media/dir1

but it didn't work

I tried this and it worked. Can anyone explain me why my initial method don't work

sudo mount -t cifs // /media/sputold_server -o username=administrator,password=877780,iocharset=utf8
share|improve this question

2 Answers 2

up vote 1 down vote accepted

Use gvfs-mount instead. The remote volume will be mounted under ~/.gvfs.

The reason you can't mount using URLs is because mount doesn't recognize URLs.

share|improve this answer
I tried that and it say "Error mounting location: volume doesn't implement mount" –  John Apr 29 '10 at 3:07
I used this command "sudo gvfs-mount smb://SERVER/wwwroot /media/sputold_server " –  John Apr 29 '10 at 3:11
Changed my post –  John Apr 29 '10 at 3:17
That would be because gvfs-mount isn't used for mounting parts of the local filesystem. Remove both the sudo and the "/media/...". –  Ignacio Vazquez-Abrams Apr 29 '10 at 3:23
Try executing export $(dbus-launch) before you use gvfs-mount`. See this answer. –  webwurst Jul 24 '13 at 19:54

Did you install smbfs ?

aptitude install smbfs

Your cifs command looks fine. If you need more informations :

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.