Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I set up a share like this:

[global]
    security = user
    map to guest = Bad Password
    usershare allow guests = yes

[vms]
    comment = VirtualBox Virtual Machines
    path = /home/neil/VirtualBox/HardDisks
    guest ok = yes
    read only = yes

And when I access the share as myself, and type in my password, it works fine:

$ smbclient //neil-ubuntu/vms -U neil
Enter neil's password: 
Domain=[SHUTTERSTOCK] OS=[Unix] Server=[Samba 3.4.0]
smb: \>

But when I access it as guest, it doesn't work:

$ smbclient //neil-ubuntu/vms -U guest
Enter guest's password: 
Domain=[SHUTTERSTOCK] OS=[Unix] Server=[Samba 3.4.0]
tree connect failed: NT_STATUS_BAD_NETWORK_NAME

Regardless of what password I type in.

Does anyone know why?

Also, why does smbclient print such useless error messages?

share|improve this question
add comment

3 Answers

up vote 7 down vote accepted

I recall a problem like this. I think it was caused by a directory permission somewhere in the path missing read. Check the directory perms are 755 for the path.

share|improve this answer
    
You're right, that was the problem in my case. If you're getting the same useless error message as me, though, it could be some other problem as well. –  Neil Apr 30 '10 at 16:56
1  
another possible reason: the share definition points to a non-existent directory. –  Felix Schwarz Apr 10 '13 at 18:49
    
@FelixSchwarz: Cheers, that's one to remember. –  Iain Apr 10 '13 at 18:53
add comment

I'll just chime in here with a different problem, but same error message. If you're using Samba < 3.2, you cannot connect to Windows Server 2008 AD servers. This includes the version of Samba included in CentOS (and presumably RHEL) 5, currently Samba 3.0.23. As of August 2011, the current version of Samba is 3.6.

I used the Samba repositories for CentOS 5 hosted by Sernet at http://www.enterprisesamba.org/index.php?id=125 to install Samba 3.4 and connect to a Win 2008 server. Don't forget to install/update winbind (yum install samba3-winbind after you add the repository) and you may need to update /etc/krb5.conf (I just moved it to a /etc/krb5.conf.bak and things work fine).

I also received Got NTLMSSP neg_flags=0x62898215 frequently in the smbclient logs.

share|improve this answer
add comment

Was just looking for an answer to this a few moments ago. This can be caused by several things. I had a similar message and the suggestions on this page worked for me.

Regards, NWis

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.