Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a legacy application (LabVIEW 7.0) running on my Sun Ultra 5 workstation running Solaris 2.6. I want to use a RHEL5 server to store all files so that I am not cluttering the small HDD on the Sun. I have found that the LabVIEW file browser has a bug which prevents it from seeing some files and folders in an NFS share mounted from RHEL5, but this problem is not present when using an NFS share mounted from another Ultra 5 using Solaris 2.6. I believe in both cases NFSv3 is being used. Is there some way I can make the RHEL5 NFS behave more like Solaris 2.6? If I make a new partition on the RHEL5 box and install OpenSolaris, will this behave more like Solaris 2.6? I am locked into using this buggy LabVIEW program, so somehow I need to make it work.

share|improve this question
    
Which minor version of RHEL5 are you using? Eg. with RHEL5.9 there is a known problem with NFS (access.redhat.com/site/solutions/306063); and NFS from Solaris to RHEL5.9 server behaves differently than to a RHEL5.1 server. –  oliver Feb 4 at 10:09
    
@oliver the NFS bug in your attached link is very similar to what I am seeing. LabVIEW has a "list files" function that is very similar to the "ls" command. This command has the same kind of problem that I see when trying to use the LabVIEW file browser. Strangely, I do not have this problem when using the ls command in bash, only when I try to list files using LabVIEW. –  joshxdr Feb 6 at 2:35
    
IIRC for me the first NFS problem was solved by upgrading to kernel 2.6.18-348.4.1.el5 (as mentioned in rhn.redhat.com/errata/RHSA-2013-0747.html) or even kernel 2.6.18-348.12.1.el5. Still have no solution for the problems between Solaris and RHEL5.9, unfortunately. –  oliver Feb 6 at 12:44
    
@oliver my kernel version is 2.6.18-128.el5. I will try to upgrade to 2.6.18-348.12.1.el5 to see if that fixes the problem. –  joshxdr Feb 8 at 12:57
add comment

3 Answers

The Ultra 5 is IDE, and if you can remove the floppy drive, there's space for another commodity internal HD of up to 120GB. That may be the easiest option of all.

share|improve this answer
add comment

SPARC binaries are compatible from 2.6 up to 10. Have you tried running LabVIEW 7.0 on a later version of Solaris ?

share|improve this answer
add comment

It's hard to tell without any references/explanations about the bug you are talking about. In any case, OpenSolaris has much better chances to match Solaris 6 implementation details than Gnu/Linux.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.