Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am having trouble getting puppet to sync a custom fact. I am using puppet version 0.25.4. The fact is inside a module as described in

If I specify --pluginsync on the command line it does sync correctly, but does not otherwise even though I have pluginsync=true in my puppet.conf.

Is it correct that this command line option and the option in the puppet.conf should have the same behavior?

share|improve this question

migrated from Apr 30 '10 at 8:17

This question came from our site for professional and enthusiast programmers.

As an aside, please consider updating to a more recent version. There's numerous known bugs in 0.25.x whose fixes will never be backported to those versions. – Felix Frank May 26 '14 at 12:42

Yes. Do you have the pluginsync=true in the right section in your puppet.conf (either [main] or [puppetd]) and do you have removed any old puppet*d*.conf?

share|improve this answer

I don't think 0.25.x supports plugins in modules. If it does it only supports them when you do not have a plugins mount point defined in fileserver.conf.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.