Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Setting runinterval=0 in /etc/puppet/puppet.conf causes continuous pulls, not no pulls. I'm trying to arrange puppet so that it will listen for puppetrun calls, but never pull without one.

share|improve this question

migrated from stackoverflow.com Apr 30 '10 at 8:18

This question came from our site for professional and enthusiast programmers.

    
What did you do in the end? –  Industrial Mar 17 '12 at 12:49
add comment

2 Answers 2

Run puppetd with --no-client option and it will just wait for the master to initiate an update.

From man puppetd:

no-client: Do not create a config client. This will cause the daemon
           to run without ever checking for its configuration automatically,
           and only makes sense when used in conjunction with --listen.
share|improve this answer
add comment

Just run puppetd with the --onetime option, and don't start it from init.d or cron.

share|improve this answer
    
This doesn't seem to preserve the ability to use puppetrun from the server to deliver pushes. –  Zed Jan 14 '10 at 16:47
    
As an additional note, setting runinterval to an absurdly huge number (say, ten years worth) works for preventing pulls after the daemon is running, but a pull will still always be started as the daemon starts. If there's any way to just prevent that initial run, that would probably solve my problem as well. –  Zed Jan 14 '10 at 16:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.