Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running qmail as part of a Plesk installation on a Debian server. Everything works fine apart from any emails sent to @nandos.co.uk.

I get no error messages they just end up stuck in the queue for eternity.

I have no idea what is going on, because as far as I can tell this is the ONLY domain the server won't send emails to.

Any ideas? TIA

share|improve this question

3 Answers 3

up vote 1 down vote accepted

As others have said, you need to check the logs to find out what QMail is seeing when it tries to deliver e-mail to that domain.

Additionally, you may wish to try to manually send an e-mail from the QMail box to the remote mail server. To do that, perform the following steps:

Find the actual mail server handling mail for example.com by running the following command from a command prompt (replacing example.com with the domain you are having problems with):

foo@bar$ host -t mx example.com

In response to that query, you'll get one or more responses of the form:

example.com mail is handled by 20 mail.example.com.
example.com mail is handled by 30 mail.example.com.
example.com mail is handled by 10 mail.example.com.

These are the mail servers designated for this domain. You'll want to take the hostname with the lowest number to work with in our next step. (If you get back the answer that example.com has no MX record, then just use the original hostname/domain name as your mail destination for below.)

Next we'll use telnet to manually connect to the mail server and attempt to send an e-mail. In the example below, I will indent the response lines the server is sending back with a few extra spaces to help clarify what you should type, and what you might get back (note, there will be some slight variation depending on mail server software).

foo@bar$ telnet mail.example.com 25

  Trying 10.1.1.1...
  Connected to mail.example.com.
  Escape character is '^]'.
  220 ****************************************
HELO your-source-hostname-here.example.org
  250 mail.example.com
MAIL FROM: <foo@example.com>
  250 2.1.0 Ok
RCPT TO: <bar@example.com>
  250 2.1.5 Ok
DATA
  354 End data with <CR><LF>.<CR><LF>
From: Foo <foo@example.com>
To: Bar <bar@example.com>
Subject: Foo -> Bar Test

This is a test e-mail from Foo to Bar.
.
  250 2.0.0 Ok: queued as BE0D91F459
quit
  221 2.0.0 Bye
  Connection closed by foreign host.

Note at the end there it gave a response of 250 and Ok. That line is signifying that the e-mail was accepted for delivery. If it had given a different response code, that would help indicate what the problem might be. The mail server might also offer additional details on the problem, as well.

Don't forget to replace e-mail addresses and hostnames with the valid and appropriate entries for your testing.

share|improve this answer

Standard location for logs in /var/log/qmail. You want to look at the logs for qmail-send.

If it is not clear and you provide the output, I should be able to provide a specific recommendation.

share|improve this answer

Check the logs for errors. You can search through the /var/log directory to locate them or google for "qmail log files" to see if you can get some help finding them (maybe this site helps?)

Once you have an error code from the logs you can google that and see what the next step is. Without a proper error from the MTA there's not much anyone here can do...first step is finding the root error :-)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.