Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My client has just got a new dedicated server running Win2008 (we had 2003 before), II7, etc. I started setting a little ASP.NET 2.0 web application we have. Running on its own AppPool 2.0.

The problem is that when I browse the site root (locally or remotely), I get 404 because the url now points to http://domain/default.php, when it should be default.aspx.

Yes, I've checked the Defaults Documents settins for the website and I deleted everything but default.aspx (default.php was not even listed).

To finish, I'll say that if I navigate to http://domain/default.aspx, the site works perfectly and I can follow links without problem.

Any idea why is this happening? Or at least where I should start looking?



  • I've already tried resetting IIS.
  • I've checked the web.config looking for some default.php, nothing found. It's the same web.config copied from the old server which has not this problem. In fact, there is default.aspx being explicity declared on the web.config as follow:

        <defaultDocument enabled="true">
                <clear />
                <add value="default.aspx" />
  • The problem seems to happen only with that website. The default website root resolves well to its default document (iisstart.htm)
share|improve this question

Restart the server. Look at web.config

Also have a gander at the configuration files themselves:

share|improve this answer
I've updated the question. None of those worked. – emzero Apr 30 '10 at 19:16
up vote 0 down vote accepted

It seems the problem happended when the website hasn't any host-header value set. Now that we've got the domain for the site and add the host-header value to the IIS Website, it now works as expected. Weird though...

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.