Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Is there a way to set windows 2008 file and folder sharing permission so you only get prompted for a password on certain shares?

That is, right now, when I got to \theserver\ I get prompted for a password despite having some shared folders that permit anonymous access.

Is there a way, asides from setting the policy sharing model to guest rather than Classic to allow a user from a non-domain pc to go to \theserver\ and see the shares and permit him or her to enter a folder with anonymous access without having to enter a username or password?

share|improve this question
    
Is the server on a domain, or a DC, or just a stand alone server on a workgroup? –  Nixphoe May 1 '10 at 5:11
    
Server is on domain –  Matt May 1 '10 at 5:15

4 Answers 4

up vote 2 down vote accepted
+150

well if you go to \\server you'll get prompted cuz you don't have permissions. if you goto \server\share and the share has guest perms on both the share and ntfs acls then you won't get prompted.

share|improve this answer
    
Thanks. I was looking for something like this. I was supposing that "Everyone" was like "Guests" didn't know there was a Guests group. –  Vinko Vrsalovic May 27 '10 at 14:26

If the user that is on a non-domain PC has a domain account that is the same user name and password they use on their non-domain PC it should connect automatically.

To prompt for certain shares can't be done. tony roth's message is correct, you are getting prompted because you don't have access. Windows will try the currently logged on users credentials though, so even if the PC is not on a domain, it will connect if the credentials are also valid in the domain.

share|improve this answer

I think this is possible IF you can edit the settings on the client(or maybe the server?).

I know from my samba server at home that my share "public" shows up when accessing the server with \server. But, if I access a password protected share, which isn't listed when browsing \server, I must provide a U/L.

On the sharing-host, you can try to edit the Local Security Policy, under: Local Policies - Security Options - Network access, and "Shares that can be accessed anonymously.

share|improve this answer

I was able to accomplish they by enabling the Guest account on the server - this is under gpedit.msc then computer/windows/security/local policies/security/AccountS:Guest account status

After doign this, I was able to enumerate shares from \server whereas before it would prompt me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.