Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

All versions of the Plesk control panel software always had this "feature" where they disable the browser password auto-complete feature. Sure, they argue it's a security measure, but it's really not.

So, how can one force the Plesk login page behave and let the browser remember the login and password fields?

Thanks.

PS: I am trying to change the actual page, not hack my browser.

share|improve this question

closed as off-topic by HopelessN00b Jan 14 at 3:43

  • This question does not appear to be about server, networking, or related infrastructure administration within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Changing line 131 in /usr/local/psa/admin/htdocs/javascript/common.js setAttribute('autocomplete', true) is not doing it. –  Gabriel R. May 2 '10 at 14:37
    
This question appears to be off-topic because it is about working with a service provider's management interface, such as cPanel. –  HopelessN00b Jan 14 at 3:43

3 Answers 3

up vote 1 down vote accepted

On Chrome you can install an "Autocomplete=on" extension, which makes autocomplete work again.

Plesk 11 has this "autocomplete=off" hardcoded in encrypted PHP files, so the common.js hack doesn't work, the extension does make it work. Also; it should survive updates/upgrades.

share|improve this answer

I've been trying to resolve the same problem, in the end the solution I went for was to create a bookmarklet so that I can click once and have the details entered into the fields without having to look them up. This does of course present security implications depending on how you safe you consider bookmarks in your browser! But for me it works well, here's the code I used for the login page on my Plesk 9.5.4 install:

javascript:(function()%7Bvar%20a=workFrame.document.forms[0];b=workFrame.document.forms[1];u=a.elements['login_name'];p=b.elements['passwd'];u.value='yourusernamehere';p.value='yourpasswordhere';%7D)();

The login page actually uses frames, took me a while to notice and then get the bookmarklet working! This code works for me using Safari 5 on Mac OSX 10.6.7.

share|improve this answer
    
Nice workaround, thanks. –  Gabriel R. May 26 '11 at 16:31

Open the server side file that produces the login page. There should be something that looks like:

automplete="off"

within the login form. It's a html form parameter. Just delete it and you should have the autocomplete back.
If you don't know which file it is, just grep for automplete.

share|improve this answer
1  
Except they do a great job at hiding it on purpose. At the same time, they will store your superuser password in clear text server-side. Sigh. –  Gabriel R. May 6 '10 at 16:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.