Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just followed How to use Group Policy to remotely install software in Windows Server 2003 to try publishing a software (MSI file). I could follow all the steps, but the supposedly successfully published software does not appear on client/user machine's Add/Remove Programs.

Could some help figure why this may not be working.

Update:

On reading this question on Experts-Exchange, tried gpresults. Output extract follows:

COMPUTER SETTINGS

The following GPOs were not applied because they were filtered out
    XADistribution
        Filtering:  Denied (Security)

    Default Domain Policy
        Filtering:  Denied (Security)
share|improve this question
add comment

migrated from stackoverflow.com May 3 '10 at 14:04

This question came from our site for professional and enthusiast programmers.

4 Answers

Have you tried forcing the policy on the ou? You may have another policy that is blocking the application of the policy. I'm assuming that the XADistribution policy is the one containing your package? Once done you can force replication(assuming more than one domain controller) and then force a group policy update with the gpupdate /force command. You can then rerun gpresult to see if the policy is being applied. With that in place I believe a reboot would be necessary to initiate the package installation.

share|improve this answer
add comment

Group Polices have security permissions. There is permission for "apply group policy" that you have to check for users/groups that you want the Group Policy to apply to. You get to the security settings throe the property button on the Group Policy tab.

share|improve this answer
add comment

The GPResult output suggests that the target computer account doesn't have permission to the software deployment policy object you created.

The target account(s) (i.e. computer accounts, in your case) need both Read and Apply Group Policy permissions, in the security settings for the GPO you've created.

Note also that if the installation isn't silent (i.e. displays UI) and you've not created a silent installation MST for it, it'll hang the computer when it boots (while waiting for invisible user input), for 15/30 minutes.

share|improve this answer
add comment

to publish a software put it under the "user"-tree. to force a software to be installed put it under "computer"-tree.

may you choose the wrong path when you are clicking the gpo together.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.