Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We just installed an option card (PERC 6/i) into a brand-new Dell PowerEdge R410 and now the system does no unattended startup but instead asks me to press F1 to continue or F2 to enter system setup after printing the following message on the console:

Fan 4 speed may change depending on system configuration and option card install.

How do I make the system ignore this "problem" or whatever that is? This system is going to be installed at a remote data center and needs to be able to restart unattended. I do not want to ignore errors completely to not get endless restart loops in case of errors.

share|improve this question

5 Answers 5

up vote 1 down vote accepted

Usually you press F2 to enter system setup and save whatever changes the hardware upgrade caused and it will stop prompting. It's not like swapping in a RAID card is done remotely ^^

But there should be an option to halt on no errors as well...

share|improve this answer
    
Well I did that, saved it. And still it persists. So this will become indeed a problem as soon as the server is moved to its remote location. –  hurikhan77 May 3 '10 at 18:15
    
Well, this really seemed to solve it. For some strange reason we had to change at least one setting and save it in the BIOS to get it update the hardware config - and then the message was gone. –  hurikhan77 Jun 3 '10 at 9:09
    
Perhaps that's an issue/bug with that BIOS version and an update is available? One can be so lucky at times ^^ –  Oskar Duveborn Jun 3 '10 at 13:24

What sort of fan configuration do you have? I'm not 100% sure, but it sounds like you may no longer be in a N+1 fan configuration based on the peripherals you've added. Adding an additional fan may clear the error.

I'm not very familiar with the 410's, though, so a quick call to Dell Support could confirm/deny my theory.

share|improve this answer
    
I like the N+1 theory and will try that next time we run into such issues... +1 –  hurikhan77 Nov 22 '10 at 13:36

Somewhere near the bottom of the first screen in the regular bios menu should be a toggle for "prompt on error" or the like. Toggle that and it won't do this anymore.

Granted its a workaround not a fix, it shouldn't be doing this.

share|improve this answer

You probably need to call Dell and see if this is a supported system config. They've been getting much more stringent about what goes in their servers. If it's unsupported, they'll let you know, and if it's supported, they'll tell you how to fix it.

They might even tell you how to turn off that warning even if the card itself is unsupported.

share|improve this answer
    
Actually, this hardware came preconfigured (including addons) from Dell. I'd expect they deliver a working hardware configuration (based on the extra hardware we ordered together with the system) although we had to insert one component on our own. –  hurikhan77 Nov 22 '10 at 13:38

I have a PowerEdge T110, with BIOS version: 1.6.4:

F1/F2 Prompt on Error "Disabled" or you can try to restore system defaults / settings

hope that helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.