Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've installed Ubuntu Server 10.04 (64 bit) on a Hyper-V Server R2. I've encountered two issues that I think are related:

  1. Very slow install
  2. Very slow command prompt

The text-mode installer goes through a series of text-based prompt windows. It takes 7-10 seconds for each of these windows to draw on the screen. The end result is that every time I answer a prompt and hit enter I wait for 15 seconds while the screen redraws line by line. I can literally see each line of text being drawn (like the old 300 baud modems days).

Once done installing, scrolling on the command line is super slow. For instance, if a simple command, like "ls", causes the screen to scroll, it will scroll very slowly.

This happens on a fresh install. The server functions as a LAMP server and an OpenSSH server, but that's it (I don't even have any Virtual Hosts set up yet). AND this only happens on the Virtual Machine console. I access the console through Hyper-V Manager and don't have this problem on any of my other Virtual Machines.

Also, this problem does NOT happen when accessing a shell through OpenSSH.

How can I improve this performance issue?

share|improve this question

8 Answers 8

To work around this issue, you need to disable the frame buffer module: edit /etc/modprobe.d/blacklist-framebuffer.conf and add the following line:

blacklist vga16fb

Reboot and the console should be fine.

This solved the problem for me. I learned about it here: http://solyaris.wordpress.com/2010/05/01/ubuntu-10-04-on-intel-driver-and-server-frame-buffer/

share|improve this answer

It looks like screen refresh performance from the console is pretty poor for Ubuntu (and I assume all Linux distros and possible DOS), even after installing the Hyper-V components. The Hyper-V integration components are part of Ubuntu 10.04. Install them and then manage using ssh.

To install the compnents, see http://blog.allanglesit.com/Blog/tabid/66/EntryId/53/Hyper-V-Guests-Ubuntu-10-04-Alpha-3-Synthetic-Devices.aspx

To install ssh, run

sudo apt-get update

sudo apt-get install openssh-server

share|improve this answer

Let me guess - you do not have enlightment components installed (are there some for ubuntu?). THis would kill a lot of things - drawing, for example, would be slow. Disc IO, too.

Are other / windows based machines fast?

share|improve this answer
    
Yes. We currently have 3 Windows 2003 VMs, 1 Windows XP VM, and 1 Ubuntu 9.10 Server in production. All the Windows VMs have integration components installed, but integration components don't exist for Ubuntu. However, our 9.10 server doesn't suffer from the same performance issues. This is the first I've heard of Enlightenments. How do I install them? Where do I get them? –  Paul Hobart May 3 '10 at 18:33
    
When I made the Ubuntu 9.10 Server VM the install was very slow, just like 10.04. But, once the 9.10 server was done installing performance was fast. –  Paul Hobart May 3 '10 at 18:46

Creds to snowsmash@ubuntu forums Disabling Framebuffer in Installer

vga16fb.modeset=0

share|improve this answer

I'm pretty sure the beta linux integration software doesn't support ubuntu, only redhat and suse. Not sure you're going to get much help here.

share|improve this answer

I believe this is a problem with how the frame buffer device interacts with the virtual display hardware Hyper-V exposes. This problem exists on Ubuntu installations dating back to at least Intrepid Ibix (at least on my machines). Integration components dont seem to matter, but fortunately after you install, you can snapshot the VM, and use that as a base for future VMs, never to use the hyper v provided virtual console again, just SSH.

share|improve this answer

I faced a slow console in a Hyper-V/Ubuntu 10.04 environment. Simply blacklisting fbcon doesn't work indeed. To really prevent fbcon from being loaded, you must configure a placebo modprobe install action. So this is the solution:

--- - 2010-06-17 16:08:53.243630658 +0200 +++ /etc/modprobe.d/blacklist-fbcon.conf 2010-06-17 12:10:02.768999669 +0200 @@ -0,0 +1,2 @@ +install fbcon /bin/false +

Don't forget to update your initramfs.

share|improve this answer

To resolve the slow install over RDP issue, set the "fb=off" boot option to disable frame buffering. It'll be nice and snappy :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.