Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

One of the prerequisites for installing SQL Server 2008 Express R2 is Windows Installer 4.5. I have a couple of WS2008 machines I'm prepping, so I downloaded the appropriate version of the file (Windows6.0-KB942288-v2-x86.msu) to our file server and tried installing it on both machines.

On both machines I get the cryptic 0x80070003 error: "the system cannot find the file specified", but it does not show which file it cannot find. I don't get this when I try to install the Windows XP version on one of my XP machines. Any clues as to what I might be missing or doing wrong?

One Technet help forum suggested I try installing the "System Update Readiness Tool", but this installer also fails for the same error code.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

The problem was from trying to run the installer off a shared drive. When I copied the file locally and ran it, I had no problems.

share|improve this answer
    
Thanks for letting us know what solved it. –  Wesley May 3 '10 at 19:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.