Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have 3 very underutilized servers that I am condensing to one of those shuttle PC's with VMWare ESXi

The HDD seems to be the bottle neck right now (the light is almost always pure solid) right now I have a single 1TB Seagate 7200.11 connected by SATA. VMWare ESXi cannot detect it when running in AHCI mode, but does when running in IDE mode. I have read that IDE mode can give a 5% performance hit which might give me enough breathing room.

However, I am open to setting up an external eSATA or some sort of raid to give me more than just the 5%. I am just weary of sinking some money into a bit of hardware without knowledge of whether it will work.

Does anyone know of resources or procedures of how to get this working.

share|improve this question
    
We tried eSATA earlier this year on ESXi, and could not get it to work. As pointed out by Xeon, you are trying to get unsupported hardware to work. We ended up going with a Adaptec 3805 SAS/RAID card and it works perfectly. –  Scott Lundberg May 3 '10 at 19:46

1 Answer 1

up vote 4 down vote accepted

Well, I hope this is not for a production system...

But to get better performance you need to get more hard drive performance. Also, need to look at your RAM usage. It could be swapping on the hard drive. Also, a single 1TB drive is slow to begin with. You need a nice RAID10 setup with 4 or more drives. SAS drives and a solid RAID card would be the better way to go. Either way, you are running ESXi on unsupported hardware to begin with so you cannot expect things to work.

share|improve this answer
    
I understand that it is unsupported (well minimally supported) but my goal is that maybe there is a workaround (to get at least the AHCI) or a budget friendly raid card that someone has been able to get working. –  MarkKGreenway May 3 '10 at 21:52
    
RAID card would be your best bet with multiple hard drives. Be careful with RAID5 as it has slow write performance. –  xeon May 3 '10 at 23:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.