Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have 2 unique networks. They both share similar architecture:

  • Windows 2003 SBS SP2
  • Running Symantec Endpoint
  • Running Symantec Information Foundation
  • Shared drives off a data partition
  • Clients running Office 2003 or 2007
  • Connect to file server through mapped drives

When users try to open a file from their local PC by double clicking, it will take 30-60 seconds to open. When they do File -> Open, those same documents open up almost immediately.

So far I've tried the following - CCleaner to parse the registry of outdated mapped drives - Disabled "using DDE" - Disabled A/V - Reboot

Any ideas beyond that? Figured this question belongs here instead of SU since its the same issue on different networks.

Edit Its only 1 user in each effected network that has reported it. They each have a document from the network share as a shortcut on the desktop. When they double click that shortcut, there is a delay. I haven't tested what happens if double clicking the document with excel or word open already. What I have done is opened up the document from the network within its respective program and it opens right away.

share|improve this question
Just to be clear. Is the office application already open when you double click on the document? – Zoredache May 3 '10 at 20:36
Is it just one client or everyone? I have dealt with Office open issues and it was due to the file type command. But it only affected a few users. – xeon May 3 '10 at 21:03
If the file is copied to the desktop is it still slow to open? How about if the shortcut is recreated? – Chris May 10 '10 at 13:50
What happens when you open the document from the share through Explorer and not a shortcut from the desktop? – Holocryptic May 12 '10 at 19:40
@Chris shortcut or copy of the document, same speed when double clicked. @holocryptic just as slow. – Keith May 12 '10 at 20:14
up vote 2 down vote accepted

I would start with Process Monitor. Capture the stack when you try to open from the shortcut on the desktop, and then a separate capture when you open from inside the program. Compare the two and see where the differences are.

Try adding the Lookup Wizard Add-in for Excel, and see if that changes anything. From here.

share|improve this answer
In addition to procexp, try doing a netstat -a while the file is opening to see if it is attempting to access other network resources that aren't available. – MattB May 15 '10 at 3:10

In your edit you said

I haven't tested what happens if double clicking the document with excel or word open already.

Test it. It could be that your users are experiencing the startup effects of Office itself. Is Word or Excel slow to startup on it's own? Are your users installing any funky Office plugins?

share|improve this answer
This sounds promising. If so, then try a reinstall of MS Office. – tomjedrz May 13 '10 at 19:08
I can open up Word and Excel from the Start menu just fine. I can then minimize the window, double click on the shortcut and its slow to open. If i do File -> Open, its quick. – Keith May 15 '10 at 0:28

Check that the user's Home Folder property on their AD account is valid, if present.

I had a similar issue which was a nightmare to troubleshoot and it turned out to be a home folder pointing to an old decommissioned file server.

location of home folder property on AD user account properties

share|improve this answer
Checked that. its clean save the login batch script we have. the script maps valid networks hares. – Keith May 5 '10 at 21:03
@Keith Is there any Folder Redirection in place? Particularly My Documents?, – jscott May 11 '10 at 13:41
negative. the files are shortcuts to files stored on mapped drives. when accessing them from the mapped drive within the appropriate application, they open just fine. – Keith May 11 '10 at 21:34

could it be something related to the file type association? i mean, the command line defined to open this file is calling a different application, or calling the same application but with different options causing the latency

share|improve this answer

If I understand correctly from your edit, your users have a shortcut on the desktop that points to the file like \server\share\document.doc and are double-clicking it to open the file.

When you're in the office app, you're going file -> Open and manually navigating to \server\share\document.doc to open it.

If this is the case, try setting the users up with a mapped drive (e.g. Z:) pointing to \server\share, and re-point their desktop shortcut so it accesses the file as Z:\document.doc

A mapped drive should hold onto network share credentials/authentication better than manually hitting the UNC share path (\) when you want to open a file. In the case of office/word, I've experienced odd slowdowns when accessing docs directly via their UNC path.

If it's occuring when accessed directly through the mapped drive, too... then you could check into this:

Some additional troubleshooting steps you could try:

share|improve this answer
Based on his comments, it is slow to open even with the document copied locally. I don't think this is a UNC issue. – Holocryptic May 12 '10 at 22:24
the UNC paths are mapped already. have been for a couple years. this slow opening of documents is a recent development. the drives are also active. – Keith May 13 '10 at 3:08

Hey Keith, have you tried running Wireshark to see what actually happens behind the scenes in each scenario? Any networking discrepancies (especially 30-60 second lags) should probably show up in there.

share|improve this answer

I had this start happening to me after I installed the newest version of Kodak Easy Share that came with my digital camera. After I uninstalled the app, my office docs started opening quickly again.

share|improve this answer
neither computer has that software installed. – Keith May 11 '10 at 12:22

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.