Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I was trying to install Exchange 2010 prerequisites, when I encountered some error. All look like the same. Like this one:
Error: Installation of [Windows Process Activation Service] Configuration APIs failed. the server needs to be restarted to undo the changes.

My server is running Windows Server 2008 R2 Standard Edition.

UPDATE: I tried installing the prerequisites one by one using PowerShell. Now I have errors on RPC over Http proxy:

Installation of [Web Server (IIS)] Tracing Failed, Attempt to install tracing failed with error code 0x80070643. Fatal error during installation.

Searching about the error code doesn't tell me much more than something went wrong when trying to update windows.
Installing Http Tracing alone also doesn't make any difference.

share|improve this question

4 Answers 4

up vote 2 down vote accepted

Reinstall (all assuming this is an empty server, which it should be for exchange).

share|improve this answer
    
Well, this one can't be called troubleshooting, but would work for sure. Thanks for the answer anyway. I hope it wouldn't happen to me again in production. –  Parsa May 4 '10 at 12:40
    
It is waht I would to do start with. I mean, seriously - thanks to install from network that is a 5 minute wait ;) –  TomTom May 4 '10 at 13:08

Try turning off UAC, rebooting & installing the pre-req's

share|improve this answer
2  
No luck. That was the first thing I did. –  Parsa May 4 '10 at 6:01

I had this problem with an IIS role service install. I was logged in as a domain admin. When I ran server manager "as administrator" it worked fine.

share|improve this answer

I've you've moved the system TEMP folders, try moving them back to the original C:\Windows\TEMP

I've seen that cause the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.