Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to block the access of one of my webapps using IP Filter in the .htaccess, the problem is that after updating the file with:

order allow,deny
deny from 58.14.0.0/15
allow from all

I get the folowing error:

Internal Server Error The server encountered an internal error or misconfiguration and was unable to complete your request. Please contact the server administrator, webmaster@example.org and inform them of the time the error occurred, and anything you might have done that may have caused the error. More information about this error may be available in the server error log.

What is wrong?

Regards,
Pedro

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Look in your server's ErrorLog and also check if AllowOverride is set to a sensible value.

share|improve this answer
    
<Directory "/home/xxxxxx/www/"> Options FollowSymLinks AllowOverride FileInfo Options Order deny,allow Allow from all </Directory> –  Pedro May 4 '10 at 17:08
    
...which obviously is not your ErrorLog. –  joschi May 5 '10 at 5:37
    
I know is not my error log!!!! Is the part of my vhost where i'm defining the AllowOverride! –  Pedro May 6 '10 at 12:48
    
There's AllowOverride FileInfo in your Apache httpd configuration which is not sufficient. You should really read the documentation section I linked in my answer… –  joschi May 6 '10 at 15:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.