Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Is there a known fix (other than upgrading from 5.1) to fix /etc/hosts from being replaced on reboot?

I discovered this behavior when running HP's Server Automation tools. HPSA sets-up a variety of local aliases for itself to use for different components to communicate wit each other.

However, after reboot, the hosts files is reverted to a quasi-plain-vanilla version: all lines above the entry for localhost are removed. Manually re-adding those needed lines below the entries for localhost works, but is non-ideal.

Is there a fix for this behavior?


I do realize that RHEL 5u1 is not officially supported for HPSA 7.8, but the hosts file resetting is not good for a variety of other reasons, too.

share|improve this question
    
Are you sure you don't have a custom script running on the host resetting the host file ? That look like your security department is playing in your back. –  Fleole May 13 '10 at 7:31
    
@Fleole - there may be .. I don't see anything, though. The boxes I've seen this on have their firewall and selinux disabled (segmented network for testing purposes). Also - 5.3 and 5.5 do not exhibit the behavior. –  warren May 13 '10 at 12:42

2 Answers 2

You have to disable kudzu.

Try first

chkconfig --levels 345 kudzu off

or

chkconfig kudzu --del

share|improve this answer
    
how does the pre-cursor to HAL alter the /etc/hosts file? –  warren May 5 '10 at 15:14
up vote 0 down vote accepted

My ultimate fix for this was to move to a newer release of RHEL (5.3 or 5.5, depending on the use).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.