Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

It seems that FF has a problem with 403 Access Denied responses from proxies, at least for ssl.google-analytics.com. I've found this post which describes my problem. I'm posting my workaround as an answer, but would also welcome any more information if anyone has it as I can't find anything!

EDIT: Note that the current version of Firefox which is experiencing this issue is 3.0.10

EDIT: Still there for FF 3.5...

share|improve this question
    
Have you logged this as a bug? FF 3.0.10 is the current version that is being pushed by the auto updater in FireFox. If the developers are aware of this issue, esp as it appears to be a regression from 3.0.9 they should fix it quickly –  Dave Cheney May 28 '09 at 15:08
    
I assumed from the post I found that someone did, but point taken. I'll follow up to ensure that it is one filed. –  squillman May 28 '09 at 15:46
    
I was also having this issue with a laptop at one of 2 work locations. This made me suspect Bilinear was right. Tried Open DNS at the location with the problem and that resolved it. –  user67623 Jan 20 '11 at 22:14
add comment

4 Answers 4

up vote 2 down vote accepted

I found Bug 492558 that sounds like exactly what you are running into. I'd recommend adding yourself to the CC list for the bug and clicking the "vote" link next to the priority.

share|improve this answer
    
+1 Thanks! Saved me a few minutes of digging. –  squillman May 28 '09 at 15:55
add comment

My workaround was this:

  1. Put an entry in your hosts file for ssl.google-analytics.com pointing to 127.0.0.1 file
  2. Use a manual proxy settings in FF
  3. Add ssl.google-analytics.com to the proxy exception list

This fails the connection to ssl.google-analytics.com and allows FF to proceed.

share|improve this answer
    
I was able to do steps (2) and (3) and get things working, trying to register a twitter account through tor. –  gregturn Jun 18 '09 at 13:39
add comment

Simple work-around for now was to mark google-analytics.com as untrusted for the NoScript extension. Credit to Brett Veenstra.

share|improve this answer
add comment

I was having trouble with the very same thing, and on several forums I saw people suggesting using addons to stop this from happening. But then I thought - why would it not just work, why isn't firefox fixing it? Now, I can't be 100% certain, but at least my issue was my ISP's DNS server, and I have a feeling everyone else having the issue is doing the same. I used Open DNS's DNS server (208.67.222.222 for preferred, 208.67.220.220 for alternate) and it fixed it right away, with no add-ons. I wonder if this could be a net-neutrality issue?

share|improve this answer
    
Not an option for us as we host our own dns. –  squillman Jan 20 '11 at 22:14
    
You could add OpenDNS servers as 'forwarders' to your domain, so if your own DNS servers dont resolve it, the forwarders will. –  JohnThePro Jan 21 '11 at 0:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.