Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

In IIS 5 files in the url: http://acme.com/_cache/cache-www.acme.com/v3.css are not accessible.

All files below "cache-www.acme.com" are unreachable. I've verified that the files exists. Permissions are not a problem. I've assigned "Everyone" to the files and give "Everyone" full rights.

What I have determined is in IIS 5 if there is a domain in the folder path, IIS 5 gets confused...

  • This fails: acme.com/_cache/acme.com/v3.css
  • This works: acme.com/_cache/acme/v3.css

Other javascript files outside the directory comedown fine...

Any thoughts?

Update/More Details**

The OS is XP SP3 running IIS 5.1. I'm working on an application that currently needs to be deployed to a remote server to run/test/debug. My goal is to use the local IIS to run/test/debug application, instead of copying the application across the wire and debugging remotely. The above issue is the remaining issue preventing me from running the site locally.

Unfortunately renaming the path isn't an option. This is a large .Net legacy application and making that type of change is not practical.

One of the below answers suggested looking for UrlScan. I was hoping it was installed, but alas it's not.

Any thoughts or feedback on this problem would be much appreciated.

share|improve this question

3 Answers 3

rename your folder?

share|improve this answer
    
I wish. This is in a huge application... unfortunately it's not an option :( –  Chuck Conway May 4 '10 at 22:00

A complete longshot, but maybe IIS doesnt know its a folder and is treating as an unallowed file extension. You could try adding a * wildcard extenion mapping. If that does work you should check on the security risk of doing that


This seems more likely: If URLScan is installed it will block dots in the path by default. If the urlscan folder is in inetsrv (C:\windows\system32\inetsrv), its installed.

Please try removing the period from the [DenyUrlSequences] section of urlscan.ini , also look for AllowDotInPath=0 and change it to AllowDotInPath=1.

share|improve this answer
    
I'll give it a try. –  Chuck Conway May 4 '10 at 22:34
    
Hi Chuck, possible new solution added to the original answer –  iainlbc May 5 '10 at 0:24
    
Rock on I'll give it a try in the morning. Thanks! –  Chuck Conway May 5 '10 at 3:40
    
Unfortunately UrlScan is not installed. :( –  Chuck Conway May 5 '10 at 15:31
up vote 0 down vote accepted

I figured this one out.

For whatever reason, when there are domain names in the folder path in IIS5 or IIS6 and IIS's Execute Permissions are configured as 'Scripts and Executables' in the 'Home Directory' tab, the files below the domain named folder not be reachable.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.