Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Possibly related to:

After manually removing MSSQL 2008 from my system (uninstall failed to remove two instances), I receive the following error when trying to re-install:

The MOF compiler could not connect with the WMI server. This is either because of a semantic error such as an incompatibility with the existing WMI repository or an actual error such as the failure of the WMI server to start.

It seems that mofcomp is failing with one of the .mof files, but I'm not sure which, or why. Digging through the connect article gave some indications, but no solution. I've run winmgmt /salvagerepository, which returns "WMI repository is consistent".

Currently, I'm unable to install MSSQL 2008. Please help!

share|improve this question
May not be your case but I've read elsewhere this could be related to the WMI Service not being installed. –  jl. May 5 '10 at 13:26
Hmm, WMI service (Winmgmt) is running. –  nbolton May 5 '10 at 14:19
Grrr Microsoft = sucks. Why am I bothering? –  Robin Winslow Jul 31 '12 at 14:33

7 Answers 7

I had the same problem and it was caused by the Firewall service. I had a warning message stating the firewall was enabled. A review of several internet sites indicated it was an issue so I continued. The MOF compiler error message did not indicate it had anything to do with the firewall. I stopped the firewall and reinstalled successfully.

share|improve this answer

I have faced the same problem and fixed it as below:

I downloadeded the portable (executable on any window based computer without installation) "Program Install and Uninstall troubleshooter" (a replacement of Windows Installer Cleanup Utility) from http://support.microsoft.com/kb/2438651 and executed the Fixit.exe. Have repeated the option named as "Fix problems with programs that can't be installed or uninstalled" to uninstalled the SQL Server 2008 registry entry(ies). After that, I installed the SQL Server 2008 which completed successfully.

share|improve this answer

Following this guide seems to do something...

... not sure if it's completely fixed the issue though.

share|improve this answer
Hmm, the error still occurs - however the installation continues from this point. I'm not even sure that's because of the above "solution"... Gah! –  nbolton May 5 '10 at 14:43

Take a look at the installation media. Assuming that you're using 32-bit for your OS, then under your setup root go into \x86\Setup\sql_engine_core_inst_msi\PFiles\SqlServr\MSSQL.X\MSSQL\Binn and take a look at that etwcls.mof file using Notepad and see if it looks fully formed like any regular class should. (Go into \x64\Setup\sql_engine_core_inst_msi\PFiles\SqlServr\MSSQL.X\MSSQL\Binn if you're using 64-bit) If you get to the bottom and are seeing brackets not being closed, etc. then this is what the problem is.

I still haven't decided what to do about this yet.... If you have the disk or ISO handy try uninstalling/reinstalling using it.

share|improve this answer

First uninstall your SQL server.

Then download this tool: http://majorgeeks.com/download.php?det=4459 (Microsoft Corp.) Windows Installer Cleanup Utility

WARNING: It is deprecated. However when I ran into this issue before I did not have a problem with it. It will allegedly cleanup your Win Install tool.

After you have ran the tool, try to install again.

Hope this helps.

share|improve this answer

I also faced the same issue, but no answers provided in the internet gave me a solution. I re-installed many times. But that did not work. Finally, I changed the instance name from MSSQLSERVER to something else. Then SQL server installed fine. I think this will help you.

share|improve this answer

Reinstall. THe server, then MSSQL.

share|improve this answer
Reinstalling Windows is not an option. –  nbolton May 5 '10 at 14:18
Then you have no option. THis is an OS level error - and I would NOT have a database server with a broken OS level function around ever. –  TomTom May 5 '10 at 15:38
It's a dev machine. –  nbolton May 6 '10 at 9:17
Even more so ;) Obviously the dev did something that damaged the OS partially ;) –  TomTom May 6 '10 at 9:46

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.