Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

On Karmic, to allow other PCs to open and X-Window on a station, one had to edit /etc/gdm.conf and change DisallowTCP to false. That file no longer exists on Lucid. I tried changing an entry in /etc/gdm/gdm.schemas (XML format) but that did not make a difference. Any ideas on where to go for this?

share|improve this question

3 Answers 3

Make the following changes

  1. Edit "/etc/X11/xinit/xserverrc"
    Delete -nolisten tcp
    File content should have the following line
    exec /usr/bin/X "$@"
  2. Edit "/etc/gdm/custom.conf"
    Add "DisallowTCP=false" line under the security section
  3. Restart gdm
  4. You are now listening port 6000 ;)

Dont forget to write "xhost +remoteip" in your local machine and "export DISPLAY=localip:0" in the remote machine.

share|improve this answer

This works for me on natty but not on maverick...

The natty machine has /etc/gdm/custom.conf but no /etc/gdm/schemas, and I only had to change /etc/gdm/custom.conf to include DisallowTCP=false in [security] section to allow remote xterm display on the natty machine (and xhost +).

However, the maverick machine (on the same network) has /etc/gdm/schemas in addition, so I changed "true" to "false" in the following section:

 <schema>
   <key>security/DisallowTCP</key>
   <signature>b</signature>
   <default>false</default>
 </schema>

Also, /etc/X11/xinit/xserverrc doesn't appear to be utilized in starting gdm, but anyway, I believe it's listening on port 6000 -- here's the result of netstat -an | grep -F 6000 on either machine:

tcp 0 0 0.0.0.0:6000 0.0.0.0:* LISTEN
tcp6 0 0 :::6000 :::* LISTEN

But I can't display a remote xterm on the maverick from the natty, while I can on the natty from the maverick...

Of course, ssh -X works both ways, but that's not what I need...

share|improve this answer

On Karmic, you can change this entry in /etc/gdm/custom.conf, inside [security] section.

share|improve this answer
    
Yeah, that worked on Karmic, but not on Lucid. Thanks though. –  user42336 May 6 '10 at 11:59
    
After you change /etc/gdm/gdm.schemas, you try to reboot ubuntu, before test? <schema> <key>security/DisallowTCP</key> <signature>b</signature> <default>false</default> </schema> –  Neto May 7 '10 at 0:03
    
I went in and also changed "DisplaysPerHost" from 1 to 2. Rebooted, did "xhost +" and it works!! –  user42336 May 10 '10 at 12:59
    
Oh, sorry, I didn't answer your question, but yes, I changed DisallowTCP and rebooted, did xhost + and it still did not work. I've tried some other changes, including adding a "custom.conf" file in /etc/gdm. I may not have remembered to do the xhost + after adding the custom.conf file though!! Hmmm....let me take that out and restest.... –  user42336 May 10 '10 at 13:04
    
Nope. It works without the custom.conf file and also with the DisplaysPerHost still at 1. I must have forgotten to do the xhost + command when I tested it. So just setting DisallowTCP to false in the schema file worked. –  user42336 May 10 '10 at 13:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.