Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Given the windows PCL separator page with escape character '\' (without quotes), how would i set an arbitrary line to red, and then the next line back to black?

heres the file so far:

\
\H1B\L%-12345x@PJL ENTER LANGUAGE=PCL
\U\L
\H1B\L&l1T\0
\M\B\S\N\U
\U\LJob : \I
\U\LDate: \D
\U\LTime: \T
\U\L
\U\L Please be sure to take only your documents
\U\L
\E

ive been asked to make the please be sure part red

share|improve this question
add comment

2 Answers

This is what I would try. Should work on any PCL printer.

\E\*r#U\&p#1yourtexthere\&p#0
share|improve this answer
    
its a lexmark c782 - i tried this and just got a blank line –  Devnull May 17 '10 at 14:09
add comment

You would use the \H command, for example, to initiate a hex character value (such as 1B for Esc) along with a sequence of characters that would be specific to a particular printer and its control language. Without knowing which printer you're targeting, that's the most I can offer.

Here's a PDF file that may be useful if you have an HP color printer:
HP PCL/PJL Reference (PCL 5 Color) - Technical Reference Manual (bpl13212)

Here's an example:

\H1B\L*r3U \H1B*v1S This is some red text\H1B\L*v0S \H1BE
share|improve this answer
    
its a lexmark c782 - i tried this and just got a blank line –  Devnull May 17 '10 at 14:09
    
@ANervousTwitch: Are you running the printer in PCL mode or Postscript mode? If you have just a line of simple text, does that get printed? –  Dennis Williamson May 17 '10 at 14:30
    
im trying to customize the PCL separator page that comes with windows. i believe its in PCL mode. other lines of simple text print fine, and if i remove the color commands from this particular line, it reappears. –  Devnull May 17 '10 at 14:43
    
@ANervousTwitch: Are you modifying c:\windows\system32\pcl.sep? That's what I'd recommend that you do. Please add the current contents of your .sep file to your question above. –  Dennis Williamson May 17 '10 at 16:07
    
thats what i was doing. contents have been added. –  Devnull May 19 '10 at 13:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.