Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have an IIS site (MOSS 2007) that uses Windows Authentication. When a user that has forgotten their password tries to login the servers keeps sending 401 requests. This means on IE the user gets three prompts before IE displays a blank page, on Firefox the user is prompted over and over until they give up.

We would like to change the behavior so if a user fails to login three times in a row we send them a redirect to a different site, instead of another 401

Forms authentication is not an option; the site has to remain on windows authentication to allow for SSO capabilities and certain sharepoint functions.

Is there any way to tweak the IIS behavior to do this?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

We managed to figure this out.

In IIS 7.0 the following changes need to be made to get custom HTML error pages to display:

Add the following to the Applications web.config after

<system.webServer>
   <httpErrors errorMode="Custom" existingResponse="Auto" >
    </httpErrors>
</system.webServer>

Then run the command "appcmd unlock config -section:httpErrors" to stop IIS giving a 500 error from these changes

share|improve this answer

If you look in the IIS site options, you should find a tab with the list of the default pages that IIS sends to web browser; take a look at http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/80cb8d8d-8fd8-4af5-bb3b-4d11fff3ab9c.mspx?mfr=true

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.