Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to set up password-less login with ssh on Ubuntu Server, but I keep getting:

Agent admitted failure to sign using the key

and prompt for password.

I have generated new rsa keys. Before the system reboot it worked just fine.

All the links lead me to this bug, but nothing works. SSH Agent is still not running.

How to fix that? Maybe the files need specific permissions?

share|improve this question
up vote 5 down vote accepted

This problem involves two machines. WHich was re-booted? ssh-add will only add the key on the client. If the key isn't accepted, there isn't a client error and a server error will only show up if the -v option is used when ssh is invoked on the client, to request the connection.

I suppose its possible too that Ubuntu the package has, for some unknown reason, altered the error message shown. It isn't an error issued by openSSH-server, as it is used in Debian (or anywhere else I've seen it, e.g. RHEL, CentOS, Knoppix, others).

share|improve this answer

just run:


on the client (your pc)

share|improve this answer
I like ssh-copy-id user@host.server.tld. – Droogans Jun 29 '12 at 20:14
Isn't it lovely when you spend an hour banging your head against the wall & the answer turns out to be this simple – connorbode Oct 28 '13 at 14:51
This should be the accepted answer! – marlar Oct 24 '14 at 7:44
worked magically! but can anyone explain what happened under the hood? – mostafiz Jul 20 at 6:03

My problem was resolved by executing export SSH_AUTH_SOCK=0, as explained in ssh Agent admitted failure to sign using the key on big endian machines on the Ubuntu bug tracker.

share|improve this answer
That disables usage of the ssh-agent all together. – The problem is not in getting rid of it, but to use it! Btw: unsetting the variable has the same effect. – Robert Siemer Dec 1 '14 at 15:53

According to the Ubuntu Bugtracking you mentioned, this is a known bug in gnupg-agent it self. so upgrading to a new gnupg-agent version >2.0.14-1ubuntu1.7 solve the problem.

share|improve this answer
This Github article mentions the same Ubuntu issue report and has some helpful suggestions including the same fix as @user46329: ssh-add. – JMcF Jan 15 '15 at 18:10

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.