Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I can't seem to figure out the problem. I've checked the deny list in CSF, and even stopped it completely, as well IPTables. Somehow I'm still blocked from accessing my server. Currently I can access it from other IPs, so I'm pretty sure that's the problem (though I could be wrong, of course. I'm no expert)

So any suggestions on what it might be, and how I could fix it, would be heavily appreciated.

I've added my own IP to the hosts.allow file, and that didn't fix it. I also added it to CSF's csf.ignore file. Again, no luck.

I'm running CentOS 5.4

All access is being blocked, I can't even get ping requests back

UPDATE: My friend suggesting pinging a different IP on the server, and it responded. So I switched the DNS to go to that IP instead, and while this is a decent bypass I'd really like to know how to fix it

share|improve this question
    
What network access service is being blocked, RDP or SSH, or ??? For that matter, what O/S is your server running? –  kmarsh May 6 '10 at 12:41
    
One second, I'll edit my question –  Rob May 6 '10 at 13:09
add comment

3 Answers

Use iptables -L to check the default policy of the chains as well as any rules that are in place. iptables -P will modify the default policy (you'll want ACCEPT), and iptables -F will flush all rules.

Additionally, you'll want to check /etc/hosts.allow and /etc/hosts.deny for any addresses in there that may match yours.

share|improve this answer
    
Thank you for the suggestions, but still no joy. My iptables is allowing everything, and host.allow as well as hosts.deny was empty –  Rob May 6 '10 at 11:47
add comment

How are you accessing your server - by name or IP?

If you are accessing by name is there an incorrect entry in /etc/hosts?

share|improve this answer
    
Both. Trying to ping it, and its not responding back. Works when I use a different IP to ping it, or access it otherwise. No, /etc/hosts is fine. –  Rob May 6 '10 at 17:57
add comment
up vote 0 down vote accepted

Well I went ahead and nullrouted the IP I couldn't connect to, and set the nameservers to a different IP. This solved it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.