Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I install .NET Framework and it shows the message saying that was all right, but when I try to run a web site the uses .NET 4, it doesn't run, because IIS doesn't find the .dlls. Even if I search for them at windows explorer, I can't find.

Does anyone had the same problem?

share|improve this question

2 Answers 2

You need to explicitly enable ASP.NET 4.0 web service extensions:

  1. Click Start, click Control Panel, click System Security, click Administrative Tools, and then click Internet Information Services (IIS) Manager.
  2. If you need to connect to a remote IIS Server, right click the Internet Information Services node and click the Connect... option.
  3. Type in the computer name for the remote IIS Server and credentials if necessary.
  4. Click the Web Service Extensions folder. The security lockdown console appears in the frame on the right.
  5. In the Web Service Extensions window, right-click the ASP.NET v4.X.XXXX, and then click Allow.

http://msdn.microsoft.com/en-us/library/aa560277.aspx

share|improve this answer

IS the web site application pool set to .NET 4 and not the default pool?

share|improve this answer
    
Yes, it is. Even the default pool is using .NET 4.0 –  Andre Nascentes May 6 '10 at 17:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.