Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

For our network we are working on building a new firewall box and we just installed Smoothwall on it to test it out. When I start up the box, before the login prompt even appears, all of the live IP traffic is appearing in the terminal (source/destination IPs, MACs, Ports, etc).

I wait for the boot sequence to finish, but all I see is this IP traffic. The login prompt never comes up. I finally get sick of waiting and press CTRL + C and it says "Entering Run Level 3" and then I get a login prompt finally.

Once I login, the IP traffic continues to fly through the terminal even as I'm trying to type commands.

How do I turn this stuff off? Is this the default setting for Smoothwall to have all this IP traffic going by on the screen? It essentially renders using the terminal to being useless.

share|improve this question
add comment

3 Answers

Not familiar with SmoothWall but I'll assume it uses IPTables or has similar usage with console display.

The IPTables script I use logs messages to the kernel logs.

On later versions of Debian to suppress the error messages I use

#dmesg -n 1

For red hat you could try

# vi /etc/sysconfig/syslog

KLOGD_OPTIONS="-2 -c 1"

# /etc/init.d/syslog restart

Reference : (removed due to this websites anti spam search google for Disable logging to console redhat)

Older Versions of Debian

# vi /etc/init.d/klogd and set KLOGD="-c 4"

Reference : (removed due to this websites anti spam search google for Disable logging to console debian)

share|improve this answer
add comment

I think the solution must lie somewhere in the configuration files of smoothwall.

Otherwise you can just try changing the name of SXX{SmoothWall-service-name} to S99{SmoothWall-service-name}, so that it starts almost after all processes have started...but that should be a last resort.

Look for the S- file inside /etc/rc.d/rc3.d for the runlevel 3.

:)

share|improve this answer
add comment
up vote 0 down vote accepted

This ended up being a bug with Smoothwall. I had to boot up the server with all NICs unplugged and then plug them in after the boot up was complete in order to avoid the nonsense. In the end I switched to pfSense anyways. Works way better imo.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.