Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Trying to install Mono from source on Fedora 7.. running

# ./configure --prefix=/opt/mono

works fine, but doing the make

# make ; make install

ends up with the following:

Makefile:93: warning: overriding commands for target `csproj-local'
../build/executable.make:131: warning: ignoring old commands for target `csproj-local'
make install-local
make[6]: Entering directory `/opt/mono-2.6.4/mcs/mcs'
Makefile:93: warning: overriding commands for target `csproj-local'
../build/executable.make:131: warning: ignoring old commands for target `csproj-local'
MCS     [basic] mcs.exe
typemanager.cs(2047,40): error CS0103: The name `CultureInfo' does not exist in the context of `Mono.CSharp.TypeManager'
Compilation failed: 1 error(s), 0 warnings
make[6]: *** [../class/lib/basic/mcs.exe] Error 1
make[6]: Leaving directory `/opt/mono-2.6.4/mcs/mcs'
make[5]: *** [do-install] Error 2
make[5]: Leaving directory `/opt/mono-2.6.4/mcs/mcs'
make[4]: *** [install-recursive] Error 1
make[4]: Leaving directory `/opt/mono-2.6.4/mcs'
make[3]: *** [profile-do--basic--install] Error 2
make[3]: Leaving directory `/opt/mono-2.6.4/mcs'
make[2]: *** [profiles-do--install] Error 2
make[2]: Leaving directory `/opt/mono-2.6.4/mcs'
make[1]: *** [install-exec] Error 2
make[1]: Leaving directory `/opt/mono-2.6.4/runtime'
make: *** [install-recursive] Error 1

I've been following the instructions at http://ruakuu.blogspot.com/2008/06/installing-and-configuring-opensim-on.html.

This is all in an effort to get OpenSimulator running.

share|improve this question
3  
Fedora 7 is a little bit ancient. You may want to consider moving up to 12. –  Ignacio Vazquez-Abrams May 6 '10 at 23:50
    
It's GoDaddy VPS hosting.. didn't have much choice. :/ –  Gary May 7 '10 at 0:07

1 Answer 1

and yeah I do check old comments but not very offen, I see you're trying to do this on a Fedora 7, I haven't tested there yet, Im also stuck with a fedora 5 on my dedicated. And about your problem, this could be anything from a missing dependency to a bug on the sources, what you can try is building and older build or a more recent one, did you try the default mono install that comes with your Fedora7? If it wasn't installed try using yum to get it, if not try what I told you first. Hope this helps

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.