Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have added umask 002 to /etc/profile, but software like git and apache still sets files to 755 instead of 775. Is there a way to force umask 002 for all programs on a machine?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

I don't know if this can be done globally but tracking down the startup scripts for the relevant software and setting the umask there should do the trick.

share|improve this answer
    
I think I found at least some of the problem. I switched to zsh and then /etc/profile doesn't seem to get loaded. Thanks for your answer. –  grm May 7 '10 at 13:54
    
Iain, I love your nomination remarks & was already 2 for 3 when I saw your "don't vote for me, vote for...". –  Chris K Nov 24 at 20:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.