Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I had this Warning with mxtoolbox. I know that it's not necessarily a big problem, but since we are having lots of issue with email delivery, I want to check everything.

I have a Exchange server 07 + Sonicwall.

My FQDN is office.mydomain.ca for send/receive connectors. When I try : telnet office.mydomain.ca 25 --> 220 MYSERVER.mydomain.local Microsoft ESMTP MAIL Service ready at Fri, 7 May 2010 10:34:36 -0400

I can change my SMTP Banner in the Sonicwall, but I don't know what to write, if there is a specific syntax or what can be the consequence if it doesn't work.

Thanks for your help.

edit: Here's the result for the SMTP test:

220 emailsecurity.mydomain.ca ESMTP SonicWALL (7.2.1.2841)

Not an open relay.
0 seconds - Good on Connection time
0.296 seconds - Good on Transaction time OK - xxx.xxx.xxx.xxx resolves to
Warning - Reverse DNS does not match SMTP Banner

Session Transcript:
HELO please-read-policy.mxtoolbox.com
250 emailsecurity.mydomain.ca [78 ms]
MAIL FROM: supertool@mxtoolbox.com
250 2.1.0 MAIL ok [62 ms]
RCPT TO: test@example.com
550 5.7.1 Unable to relay for [78 ms]
QUIT 221 2.0.0 Bye [62 ms]

share|improve this question
add comment

3 Answers

up vote 2 down vote accepted

In the SMTP service of Exchange there is a special setting to override the hostname exposed by SMTP server during SMTP greeting. I think it is inthe same window of the smart host setting (sorry I don't have an exchange server at hand right now)

share|improve this answer
    
+1 for the only one knowing what the OP talks about ;) –  TomTom May 7 '10 at 16:16
    
img208.imageshack.us/img208/75/smtpbanner.jpg (10.10.10.111 is my Sonicwall) This is it ? –  Bastien974 May 7 '10 at 20:13
    
Can someone confirm please ? –  Bastien974 May 20 '10 at 15:06
    
Bastien974: correct, that is the window. Note that if yoi use the square brackets you override the DNS lookup. –  lrosa May 21 '10 at 4:52
    
You mean the [10.10.10.111] as it is already ? I doesn't override right now, if I click the checkbox it will ? –  Bastien974 May 25 '10 at 13:35
show 2 more comments

You need to Type in the FQDN of your Domain MX Entry

Make follow on the Shell

nslookup set q=mx

And here we are you see the MX Host A-Record Name of your Domain This you need to use on your smtp banner.

Something simmaler to this mx.google.com<123.123.123.125>

Hope this helps.

share|improve this answer
add comment

The response you're getting via telnet is different that the one you're getting from MXToolbox, but I'm assuming you've setup your SonicWall as an SMTP relay for your Exchange Server.

You can set the banner to whatever you wish as long as it starts with 220. To have it match, just put "220 office.mydomain.com ready" in the SonicWall where you configure the banner (it may actually put the 220 in for you, I don't know, as I don't have any SonicWall experience).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.