Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For my site i need to have www included but currently it's saying Under Construction when i go to the site with www.

For example: - gives me Under Construction - works fine

Where is this configured is it something in IIS or is it something the my ISP should configure?

share|improve this question

migrated from May 7 '10 at 23:50

This question came from our site for professional and enthusiast programmers.

If you nslookup and nslookup do they both resolve to the same address? If so then you need to set up the host header for the www one on the server. If not you will need to set up the 'A' record first then sort out the host header if required.

share|improve this answer
+1 for being the only one to consider the DNS side of it. – John Gardeniers May 8 '10 at 2:43

Something your ISP should configure in IIS - assuming you use shared hosting you do that yourself somewhere in the control panel.

If you self-host.... go to IIS control panel and look at the site BINDINGS. You miss one for

share|improve this answer

the www is the "subdomain"

your domain name has a configuration which allows you to say the servers which should handle connections to particular domains.

Normally you would configure * to point to the server you are hosting on using an "A" record.

Depending on how you have obtained your "website" you may or may not have access to these settings. Commonly the service provider takes care of this and hides it behind their own configuration interface.

You may also be able to use a redirection alias at the domain level to make * resolve to

share|improve this answer

The best would be to configure IIS.

See it on IIS: Redirect a domain such as to

Or see a more general guide at Microsoft Technet

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.