Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a server and a box that cannot communicate, a server(fedora 12) with two nics on it, directly connected to say and the route table looks like this

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface   UG    0      0        0  eth0     *       U     0      0        0  eth1

eth0 =
eth1 =

and a directly connected user (Mythdora) on the network with ip and route table like so

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface     *        U     0      0        0  eth0

the cable is a crossover and it works all three nics work

share|improve this question

2 Answers 2

Try not to state your actual problem at the very end prefaced with "as a note", but I think I get what's going on here after reading through a few times.

Clearly you have two machines you want to connect on One of them is intended to act as a router to the network.

First, I don't think this is necessarily the cause of your problem, but it doesn't make sense for your server, directly connected to the subnet as, to have a route for the subnet which is another machine on that subnet. Maybe explain what you were trying to accomplish here.

Your laptop test may be flawed, or you may simply have explained it confusingly. You should only be able to ping the server using a 192.168.2 address when connected to the NIC which is configured for that network.

I don't mean to be overly critical of how your question was asked, but I often find that when I am flustered with a situation and it doesn't make sense, explaining it in a way that I feel others should understand helps me to find the answer myself. :)

share|improve this answer
yeah I get what you're saying I was annoyed and spewed a bunch of crap on the post. I updated it and I hope that is a little more explanatory, thank you. – jtzero May 8 '10 at 22:47
up vote 0 down vote accepted

so i solved it, i narrowed down and deleted all the routing except between the box and mythdora and still nothing, I then gave up and installed mythbuntu. worked without editing iptables

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.