Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running Centos 5.4 with 750GB(ntfs) and 2TB drives for storage. Originally I installed the 750, everything seemed fine and then I installed the 2TB drive with NTFS already partitioned. I noticed when I would copy a lot of videos it would crash (no mouse or response from server) about 20min into it. After doing some troubleshooting I noticed the 750 would also crash when doing the same task so I decided that NTFS may be the problem. I unmounted the 2TB drive and tried to partition and format it using ext2 but when using parted it would crash at this point "writing inode tables". Looking at the dmesg logs I believe this is the error "mtrr: type mismatch for e0000000,10000000 old: write-back new: write-combining". Any idea as to what could be causing this?

share|improve this question

migrated from May 8 '10 at 17:15

This question came from our site for professional and enthusiast programmers.

This is also happening when I try to copy a lot of files into my home directory. So it's not just the storage drives but the Centos drive also. – Chad May 8 '10 at 19:54
How are you connecting the storage? Usb? firewire? Directly via Sata/esata? – Pier Jun 24 '10 at 8:13

mtrr is Memory Type Range Register. P6 CPUs have this register, and it is used to combine memory writes before sending them out over the bus which should result in higher performance.

That is supposed to be an informational message that your system is speeding things up over the default config for your system. It would happen when you are doing large transfers as the system will recognize that it needs to switch to write combining, which is faster.

However, there are a number of cases we've had where that switch has caused system instability or a kernel panic.

You might try:

echo "disable=2" >| /proc/mtrr

to see if it eliminates the issue.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.