Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Instead of booting into the running system this machine stops and on the terminal I can see a message:

could not stat resume device file /dev/sdb5 

When I attach a keyboard and press enter the boot continues and the machine comes up like normal.

But it's essential that this machine comes up under most circumstancs alone.

There never was something like a "resume" on this machine.

I tried several times to reboot, but this does not happen on all boots, I can not find a pattern here.

There is a software raid running on the box.

How can I get rid of this boot failure?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Sounds like sdb5 is supposed to be swap, but it's broken. It can be fixed by using swapoff /dev/sdb5 to make sure it's not in use, then mkswap /dev/sdb5. Of course, you should consult your system installation notes to verify that it should be a swap partition first.

share|improve this answer
    
You solved it, thank you! I did just remove the sdb5 swap line from fstab, it was from an old install. There is another swap partition now, which is in use and works. So there were 2 swap entries in fstab. –  user12096 May 9 '10 at 12:54
    
Having multiple swap entries isn't necessarily a problem. Linux will balance accesses between the various swap partitions in order to optimize for speed. –  Ignacio Vazquez-Abrams May 9 '10 at 13:02
    
Amazing. Good to know. Well in this case the partition did not exist anymore. –  user12096 May 9 '10 at 13:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.