Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

In AWStats under: "Links from an external page (other web sites except search engines)" it has generated a list of pages that had linked to my page. I see pages like: Bing, YouTube, HotFrog, etc.. However, there are many internal links within the pages. Towards the bottom it is reporting as followed:           5     2.4 %                   5     2.4 %                   4     1.9 % 5     2.4 %       5     2.4 %                 10     4.8 %                   5     2.4 %                  5     2.4 %              10     4.8 %       5     2.4 %

Note: Static IP was set in place because of the SSL requirement.

share|improve this question
Could it be that my client is referencing the whole URL to his pages in his navigation? i.e: website.com/products.html vs products.html –  Austin May 19 '10 at 13:37

2 Answers 2

Because your site is also being visited by it's IP-address (without your domainname). AWStats doesn't know this is the same website unless you configure the HostAliases configuration directive. Add this to your AWStats configuration:


Another solution would be redirecting visitors who visit your website by it's IP-address to your domainname (I would recommend this anyway). You can do this with mod_write and a .htaccess file:

RewriteEngine On
RewriteCond %{HTTP_HOST} !.*?your.domain$ [NC]
ReWriteRule /(.*)$ http://www.your.domain/$1 [R=301,L]
share|improve this answer
I went to my awstats.conf file and found the following HostAliases="www.oggiegrip.com oggiegrip.com" Would it be bad to overwrite this with what you suggested? Or should I just go the .HTACCESS route? –  Austin May 10 '10 at 13:40
Add the IP address to the existing HostAliases separated by a space. And check the .htaccess, people are visiting your site by it's IP address, you don't want that ;). –  PowerSp00n May 10 '10 at 13:41
When adding to the HostAliases file do I need to recompile a .pl file? –  Austin May 10 '10 at 13:51
Also, I see the rewrite Condition you advised but I tried that and it failed to work. Instead I'm using: Options +FollowSymlinks RewriteEngine On RewriteBase / RewriteCond %{HTTP_HOST} ^oggiegrip.com ReWriteRule (.*) oggiegrip.com/$1 [R=301,L] –  Austin May 10 '10 at 14:04
You don't need to recompile AWStats after altering the configuration, just let AWStats analyze your logfiles. Not sure if AWStats will remove the existing IP Address from the list of sites linking to you. –  PowerSp00n May 10 '10 at 14:05
[johnathan@VM:~] $ host
Host not found: 3(NXDOMAIN)

You need to setup reverse DNS for that IP so that your web server can map the IP back to a domain name. Your ISP can normally help you with this, alternatively, if you're running the server from your home IP look into something like the Free services offered by dyndns.org.

[johnathan@VM:~] $ host 109.xxx.xxx.131 domain name pointer starscream.xxxxxxxxx.com.
[johnathan@VM:~] $ host starscream.xxxxxxxxx.com
starscream.xxxxxxxxx.com has address 109.xxx.xxx.131

That's the sort of return you should get ... just for reference.

Hope this helps :)

share|improve this answer
I'm not running this from home. Is it only possible to create a reverse DNS by contacting the ISP? –  Austin May 10 '10 at 14:13
Also, what are you running to use that host command? I tried SSH'ing to a *nix box but was unable to use that. –  Austin May 10 '10 at 14:30
apparently the Linux box I was on didn't have that command so I ssh'd to another server. –  Austin May 10 '10 at 14:36
Referring sites has nothing to do with reverse DNS. @Austin: your .htaccess doesn't work yet. You'll have to forward to your domain. –  PowerSp00n May 10 '10 at 15:02
@PowerSp00n, seems to be working fine on my end. When I try oggiegrip.com it immediately adds the www. prefix. –  Austin May 10 '10 at 15:05

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.