Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am using ubuntu on my server.

i am behind router.

There is another server in my company where someone has forwarded the port 5900 to.

SO can i change something in my ubuntu so that i can connect using VNC on port 5905

share|improve this question

1 Answer 1

Maybe the Set as default option was overlooked. This process allegedly fixes the issue of the port change not taking even after a reboot.

  1. Open Gnome Configuration Editor - gconf-editor (can use ALT-F2 for quick access)
  2. Open Folder Desktop
  3. Open Folder Gnome
  4. Open Folder remote_access
  5. In right had pane:
  6. Right Click on alternative_port and click on edit key
  7. Enter desired port number
  8. Click OK
  9. Again Right Click on alternative_port and click on Set as Default (this is important)
    1. Enter the Admin password for Authentication and click on Authenticate
    2. Right click on authentication_methods and edit key – and set to vnc
    3. Put a check in the check box for enabled
    4. Put a check in the check box for use_alternative_port
    5. Click on File and Close Window
    6. Reboot the system

Source: http://ubuntuforums.org/showthread.php?t=1297290

share|improve this answer
    
I have entered 5905 as port number and made true the use alternative port but still i can't connect using ip:5905. i have restarted the system as well. ip:5900 works –  John May 11 '10 at 3:29
    
In the authentication_methods , i have no option set , it says none. and after doing all other setting , i still can't access that –  John May 11 '10 at 5:37
    
And it still works on 5900? Are u going through the firewall? Im thinking its got to be something simple –  iainlbc May 11 '10 at 5:43
    
yes , it works on 5900 , i don't have any firewall –  John May 11 '10 at 6:00
    
I will try to reproduce the problem on a server at work tomorrow :) –  iainlbc May 11 '10 at 6:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.