Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

OK, so I want to take advantage of the Apache server that comes installed on my Mac OS X system (which means, I would like not to have to install my own version of Apache and I might as well try to use what comes bundled), and as such, I went to change some settings in the configuration file:

/etc/apache2/httpd.conf

Namely, I changed the these two lines:

DocumentRoot "/Users/myusername/Sites"

<Directory "/Users/myusername/Sites">

So that they initially pointed to a folder in my Dropbox folder (so I could have my docs sync to my Dropbox):

DocumentRoot "/Users/myusername/Dropbox/public_html"

<Directory "/Users/myusername/Dropbox/public_html">

That didn't work. So then I figured, ok maybe it was too much to ask to make folder in my Dropbox be my document root. So then I thought, what if I make the Document root another folder of my choosing like so:

DocumentRoot "/Users/myusername/dev-sites/public_html"

<Directory "/Users/myusername/dev-sites/public_html">

and that didn't work either. After looking within the httpd.conf file for clues it seems that only two directories appear to work as Document root paths for the Apache that comes bundled with Mac OS X:

/Users/myusername/Sites  (or ~/Sites)

and

/Library/WebServer/Documents/

But trying to use any other directories didn't seem to work. I would get 403 errors on my browser. I was wondering if there was some other settings to change on the httpd.conf file or any permissions to set to make this work.

Any help would be appreciated and many thanks in advance.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Check the permissions of the folder you want to use instead of ~/Sites

share|improve this answer
    
Agree! 403 is a permission denied message. Change the ownership of the new folder to match the default folder or open up the access permissions. –  Chris Nava May 11 '10 at 19:57

if you have no index.(php|html|...) in this folder and you want apache to show a list of file, you need to enable indexes.

Either you put "Option +Indexes" in you vhost configuration, or you put "AllowOverides All" in your vhost and a .htaccess file in your DocumentRoot directory with "Option +Indexes".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.