Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Built a brand new server, with a fresh copy of Windows Server 2003 x86 Enterprise Edition w/SP2.
Installed the .NET Framework 1.1, 2.0, 3.5, and 4.0
Added the "Domain Controller" and "Application Server" roles.
Created a new website, pointed it to a local directory: C:\Inetpub\angryoctopus.net\
Added the appropriate host headers: angryoctopus.net, www.angryoctopus.net, TCP port 80, all IPs
Moved the website content into the local directory.
Configured the default document in IIS: Default.aspx
Enabled ASP.NET for this website, and set it to the correct version: 2.0.50727
Configured the zone angryoctopus.net in DNS. Tested DNS lookup here to ensure DNS was functional.
Opened website in VS 2008 and re-built (and debugged) to ensure the content was functional.

I can clearly see that IIS is responding normally, by browsing directly to my server's IP address. Since this does not use the angryoctopus host header, the default website is displayed instead: the "Under Construction" page.

And yet, after all of this, angryoctopus.net still returns 404.

Does anybody know what could be wrong? What troubleshooting steps have I forgotten? Is there a command-line diagnostic that might provide more information?

EDIT: I should add that this server is behind a firewall with redundant wan connections, and that it's local IP address is different: 10.0.0.10 I don't know if this has any effect, but I thought I'd mention it just in case.

Here is a snippet of the log file for this website. This event occured when I clicked on the Default.aspx link above. The log doesn't seem to record any events for the other links...

2010-05-11 20:31:26 W3SVC1635707849 10.0.0.10 GET /Default.aspx - 80 - 10.0.0.1 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+5.1;+Trident/4.0;+.NET4.0C;+.NET4.0E;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729;+Creative+AutoUpdate+v1.40.01) 404 2 0
2010-05-11 20:31:43 W3SVC1635707849 10.0.0.10 GET /Default.aspx - 80 - 10.0.0.1 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+5.1;+Trident/4.0;+.NET4.0C;+.NET4.0E;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729;+Creative+AutoUpdate+v1.40.01) 404 2 1260

EDIT 2: I have confirmed that the website does in fact serve plain HTML pages without any problems. The error only occurs on ASP pages (including the ASP page in the center IFrame in that link).

EDIT 3: Here is a screenshot of my Web Service Extensions in IIS:

Why aren't ASP.NET 2.0 and ASP.NET 4.0 in the list? They show up just fine in the website properties:

share|improve this question
1  
I can't help with the question, other than ask what's in the server logs, but I am wondering why this public facing web server is a domain controller. –  John Gardeniers May 11 '10 at 20:08
    
@John Gardeniers: Because I'm too cheap to build more than one server in my house. :-) This server is needed for both my and my wife's buisnesses. It needs to provide the domain-level security, plus a ton of storage space (4TB) for my wife's photo shoots (~5GB each), and host our website(s). We prefer to host the websites manually, since we like the level of control, as well as the development freedom it provides. –  Giffyguy May 11 '10 at 20:18
add comment

1 Answer

up vote 2 down vote accepted

Based on the log file, you are getting a 404.2 error message. This typically means "web service extension lockdown policy blocked the request".

Since you are trying to load an ASPX page, go into IIS manager and go to the "Web Service Extensions" category. Ensure that the ASP.Net extensions are Allowed.

share|improve this answer
    
I hadn't thought of this! Thanks. You may have pointed me in the right direction, but this has made the problem a little more complex. See EDIT 3 above for details. –  Giffyguy May 11 '10 at 21:14
    
Fixed it! I needed to add the appropriate Web Service Extension DLLs to the WebService Extension list for ASP.NET 2.0 and 4.0. Then I had to add permissions to the folder C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files giving both LOCAL USER and NETWORK USER full access to This folder, subfolders, and files. Everything works like a charm! Thanks again for pointing me in the right direction. –  Giffyguy May 11 '10 at 21:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.