Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We have a .NET 1.1 application that we keep on a netowork share. We install the .NET Framerwork to the local PCs and also set the full trust via the following: %windir%\Microsoft.NET\Framework\v1.1.4322\caspol -pp off -cg LocalIntranet_Zone FullTrust

This has worked fine on all PCs to date however now we have a few new PCs with Win7 and the process no longer is working. The app will run fine from a local drive in Win7 but running the networked copy results in a general exception error.

Any ideas on how to get this to work under Win7?

share|improve this question

migrated from May 12 '10 at 1:19

This question came from our site for professional and enthusiast programmers.

Have you tried less restrictive UAC settings, or turning UAC off? – Rick Mogstad May 10 '10 at 13:07
UAC is set to never notify. – schooner2000 May 10 '10 at 13:57
If you run caspol.exe -rsg \\server\share\app.exe what zone is it appearing in? – Colin Bowern Sep 10 '10 at 16:22

Not really sure. Caspol can require some tinkering to get it right. Just a hunch: if this is x64 Windows 7, try running caspol from the Framework64 folder.

C:\WINDOWS\Microsoft.NET\Framework64\v1.1.4322\caspol.exe -m -ag 1 -url "file:////\\computername\sharename\*" FullTrust -exclusive on

share|improve this answer

You have to make sure that the command prompt you run caspol from is launched with "Run As Administrator".

Just being in the Administrators group is not enough, you need the above to bypass UAC.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.