Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

One of my coworkers just got a new laptop running Windows 7 Pro x64. We use a GPO to deploy the printers to every system, but for some reason it is not working on this system.

I have been breaking my head over this for the past 3 hours now without any result. The strange thing is that gpresult /H seems to indicate that the GPO did run.

The hardware:

  • Laptop: Windows 7 Professional x64
  • Print server: Windows Server 2008 x64 R1
  • HP Color LaserJet 2605dn
  • HP LaserJet P2015
  • Driver packages on server: HP universal printer driver PCL5, both X86 as X64

Oddities and other info:

  • GPO working flawlessly on every other system, including my own Windows 7 Ultimate X64 laptop
  • gpresult /H shows the GPO being ran
  • Windows Firewall completely disabled on the new laptop

Below is the output for gpresult /H (in Dutch sadly, but I think you'll recognize it):

Pad Dominerend groepsbeleidsobject
\\Server2008\HP Color LaserJet 2605dn   Printers
\\Server2008\HP LaserJet P2015  Printers
Beleidsdefinities (ADMX-bestanden) opgehaald van de lokale computer.
Beleid  Instelling  Dominerend groepsbeleidsobject
Beperkingen van point-and-print Uitgeschakeld   Printers

Like I said, I have been trying to figure this out for the past few hours or so without any result, so you are my last hope.

Any help is appreciated.

share|improve this question

5 Answers 5

Is the driver already installed on the Clients? I am thinking that perhaps the users do not have permissions to install the initial driver and that is causing the addition to silently fail.


If they don't exist already on the client you need to ensure that the point and print restrictions are set to allow silent driver installation. In a mixed environment (both win 7 and prior clients) you need to set it in both User Configuration\Policies\Administrative Templates\Control Panel\Printers and Computer Configuration\Policies\Administrative Templates\Printers.

set it to not show the elevation prompt

share|improve this answer
No it is not. The driver packages reside on a shared folder on the server which should be readable to all users. Is there any way to check this? –  Aron Rotteveel May 12 '10 at 13:48
See my update for more details. If it's not installed there are additional GP settings –  Jim B May 12 '10 at 14:11

See if my previous answer on this helps:

share|improve this answer
I have set this user policy, but for some reason, it is not showing under the 'computer configuration' section. –  Aron Rotteveel May 12 '10 at 13:55
Are you editing the GPO from a Windows 7 or Windows Server 2008 R2 machine? The policy setting under Computer Configuration did not exist in older versions. –  ThatGraemeGuy May 12 '10 at 15:58

Try turning off UAC on the affected computer and see if it makes a difference.

share|improve this answer
Something I haven't tried yet; could it make the difference? My own computer is using UAC as well and works fine... –  Aron Rotteveel May 12 '10 at 13:30
Tried this now, but without success. –  Aron Rotteveel May 12 '10 at 13:46

Check the group policy event logs on the effected machine.

share|improve this answer

If you're still having this issue. Have you tried this MS fix?

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.