Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have created a small .Net 4.0 website and installed it on my SharePoint server as a separate web site in IIS v7 (using port 8008 for now). I had to install the .Net 4 framework, set up the database, etc. and this all went smoothly and my app works as a standalone website.

Now I am trying to get pages from my website to show up in SharePoint 2007. For various reasons (the SharePoint site is using SSL, security, etc.) I now need to move my .Net app to run under the SharePoint 2007 site in IIS. I have added it as an 'Application' and set it up with the same .Net v4 application pool and settings that were working when it was set up as a standalone site.

Now when I try to access the application I get the error at the end of this description. Any help would be greatly appreciated. I already tried following the instructions on this post:

but that did not help.

Here are the error details:

Log Name:      Application
Source:        ASP.NET 4.0.30319.0
Date:          11/05/2010 11:49:31 AM
Event ID:      1310
Task Category: Web Event
Level:         Warning
Keywords:      Classic
User:          N/A
Event code: 3008
Event message: A configuration error has occurred.
Event time: 11/05/2010 11:49:31 AM
Event time (UTC): 11/05/2010 3:49:31 PM
Event ID: 559d7ac619344f3499a4a31c6c9e58cd
Event sequence: 1
Event occurrence: 1
Event detail code: 0

Application information:
    Application domain: /LM/W3SVC/1653978112/ROOT/bidmonitor-1-129180665715766107
    Trust level: 
    Application Virtual Path: /bidmonitor
    Application Path: C:\inetpub\wwwroot\bidmonitor\
    Machine name: GGI-SP1

Process information:
    Process ID: 5272
    Process name: w3wp.exe

Exception information:
    Exception type: ConfigurationErrorsException
    Exception message: Could not find permission set named 'ASP.Net'.
   at System.Web.Hosting.ApplicationManager.CreateAppDomainWithHostingEnvironment(String appId, IApplicationHost appHost, HostingEnvironmentParameters hostingParameters)   at System.Web.HttpRuntime.HostingInit(HostingEnvironmentFlags hostingFlags, PolicyLevel policyLevel, Exception appDomainCreationException)

Request information:
    Request URL:
    Request path: /bidmonitor
    User host address:
    Is authenticated: False
    Authentication Type: 
    Thread account name: NT AUTHORITY\NETWORK SERVICE

Thread information:
    Thread ID: 3
    Thread account name: NT AUTHORITY\NETWORK SERVICE
    Is impersonating: False
    Stack trace:    at System.Web.HttpRuntime.HostingInit(HostingEnvironmentFlags hostingFlags, PolicyLevel policyLevel, Exception appDomainCreationException)
share|improve this question
up vote 1 down vote accepted

Officially I don't think this configuration is supported yet. See the ASP.Net 4 breaking changes whitepaper.

Unofficially, you should be able to fix the problem by changing the trust level in your web.config file from WSS_Minimal to Full. This is NOT recommended though.

share|improve this answer
Thanks MattB, I had tried setting the trust level to Full and that did not seem to help, although I might have other problems. The link you supplied does seem to preclude what I am trying to do... – Craig Nakamoto May 12 '10 at 18:44
@Craig: did you try in your local apps web.config, or in the SharePoint web.config? I think it has to be at the SharePoint level, but not sure. – MattB May 12 '10 at 19:46
I only tried my local web.config, but I have moved on now and will just set up a separate ssl certificate for my app. Thanks again Matt! – Craig Nakamoto May 12 '10 at 20:02

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.