Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I having an odd issue where a particular page doesn't finish loading... all the time. Intermittenly, this page doesn't finish loading - in particluar, it seems maybe the JS file isn't downloaded or finished loading.

Marchelos Law

I am not sure how to troubleshoot this issue, since refreshing it fixes it. I see it mostly in IE 7 & 8, rarely in Safari or FireFox.

If you view the page in question, refreshing it - you should see the issue. Any ideas?

Update: My server confirmed all files have been sent with a 200 or 304 status, so it sounds like its not a server issue.

share|improve this question
add comment

3 Answers 3

Seems to have loaded OK on the first try from here (Chrome). Like you had said, this is typically due to some incorrectly loading JavaScript files.

The best thing to do is to run Y!Slow for Firebug (Firefox) and load up the page. This should give you an idea as to what scripts are loading and where any slowness is coming in. You can also use the Developer Tools in Google Chrome to diagnose performance problems.

Generally speaking, the best thing to do is to combine any JS scripts into one file, as well as any external CSS content. The less requests the browser is making to disparate web servers, the faster the site will load and the less chance it will get 'stuck' at a slow server which may or may not be under your control.

share|improve this answer
    
Good suggestions Dave, I'll talk to my host. It's on a shared server so maybe something there is an issue. The one JS ySlow marks against is putting the scripts at the bottom. But that should not affect loading. The scripts seem to actually get stuck. I'll continue on. Again, in IE is really where I see it happening. Thank you! –  Richard Testani May 12 '10 at 19:11
add comment

I have found Fiddler2 a great tool for figuring out why pages are slow.

Fiddler2

share|improve this answer
add comment

Everything Dave said sounds good to me, and that page loads fine for me. Two generic remaining (although maybe less likely) things to check are:

  1. The logs, always check the error logs of the web server :-)
  2. Are these clients behind a proxy maybe?
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.