Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to install a service on a Windows Server 2003 machine which is supposed to listen on port 80 but it fails to start because some other service is already listening on that port. So far I've disabled the IIS Admin service and the HTTP SSL service but no luck.

When I run netstat -a -n -o | findstr 0.0:80 it gives me the process id 4 as the culprit, but when I look at the running processes that process id points to the "System" process.

What can I do to get the System process to stop listening on port 80 and get my service to listen instead?

share|improve this question

3 Answers 3

up vote 6 down vote accepted

In W2K3, the kernel-mode driver HTTP.SYS listens for incoming HTTP and HTTPS connection attempts. You can configure the binding behaviour with the httpcfg.exe set iplisten -i x.x.x.x:y command. Have a look at some usage examples and the syntax and you'll figure it out.

share|improve this answer
1  
Or you could just configure any web site configured to listen on port 80 to listen on another port. ;) –  joeqwerty May 13 '10 at 3:02
    
So you're sticking with the Unicorn then? –  joeqwerty May 13 '10 at 3:09
    
If the service in the question uses HTTP.SYS it should be able to work alongside IIS, both on port 80. If not (i.e. the service opens port 80 directly) then nothing else (including any service or application that uses HTTP.SYS) can use port 80. –  Richard May 13 '10 at 8:22
    
That did it. I had to delete port 80 from the iplisten list for HTTP.SYS. –  Miky Dinescu May 13 '10 at 15:52
    
we cant find httpcfg on windows 2008 but other articles refer netsh to reconfig it. but i cant work with netsh. please help me. –  saber tabatabaee yazdi Jan 14 '13 at 10:05

The IIS Admin service wouldn't be installed if the World Wide Web Publishing service wasn't also installed, so that's my guess as to what's listening on port 80. Have you checked to see if the World Wide Web Publishing service is running? You'll probably find that it is. You'll need to stop it or configure the default web site (and any other web site) to listen on a port other than 80.

share|improve this answer
1  
I've already disabled the World Wide Web Publishing service and it didn't change anything. I'm at a loss.. –  Miky Dinescu May 13 '10 at 13:05
    
We 've already disabled the World Wide Web Publishing service –  saber tabatabaee yazdi Jan 14 '13 at 10:11

Please, check this site: http://www.devside.net/wamp-server/opening-up-port-80-for-apache-to-use-on-windows. In my case, the port 80 was being used by HTTP.SYS. I followed these steps, described on the previous link:

Control Panel > Device Manager
In menu View, select: Show hidden devices
Open tree: Non-plug and Play Drivers
Double-click: HTTP
Tab Driver - Group Startup
Switch from: Demand to Disabled

Best regards,

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.