Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a new Dell R710 server running Windows Server 2008 R2. I one of it's 4 nic's set up and the rest are not being used. I have successfully given it an ip address, network mask, and dns servers. I can ping and resolve this machine from anywhere else in the network. However, when I try to connect to it via RDP it does several things:

1) it might just outright refuse me with the message, "This computer can't connect to the remote computer. Try connecting again." 2) it might connect me and let me chose the account I would like to log on as... but when you select an account then you receive the same message as in #1 3) it might actually allow you to connect but only for about 1 minute and then you receive the same message and it closes your session.

I have configured the firewall service to allow for RDP over the domain network connection. This didn't have any noticible effect. I have now disabled the firewall for all 3 networks and have even stopped the Windows Firewall service. I am still having the same issue.

I am new to Server 2008 R2 and things are very different. Please give me any advice you can on how to resolve this issue and/or any other gotchas that are sure to come my way. The 2003 -> 2008 learning curve seems steep.

Thanks

Update #1: I appear to be getting disconnected even when accessing network resources (file share) from the server in question. This is a Dell R710 which has 4 nics. I have only one connected and configured. I would think that these connections need not all be set up but perhaps I'm wrong?

Update #2: The same thing happens when I navigate to the default administrative share on the R710 server. About 50% of the time when I navigate from one directory to another I get the same message as stated in a below comment, "The computer can't connect to the remote computer. Try connecting again. If the problem continues, contact the owner of the remote computer or your network administrator". If I continue to try the same directory eventually I get in. Is this some sort of intelligent firewall service?¿

Update #3: I downloaded the latest Broadcom Nexxtreme II drivers for 64bit win 2008. Windows is telling me that my drivers are up to date. I also just tested RDP from the 2008 server to my XP SP3 workstation and it works fine. I would think at this point that the nic is operating fine. I also have several file shares that can be accessed in both directions. I feel as though this must be a firewall issue but when I turn off all firewalls for testing the same symptoms occur. Anyone have any more suggestions?

share|improve this question
    
The 2003 to 2008 curve wasn't terribly steep, but now you're jumping 2 generations from 2003 to 2008 R2; that's like going from Win98 to XP. –  Chris S May 13 '10 at 13:57

5 Answers 5

Sounds like your using an XP client to connect, where network level authentication wont work. I haven't found any way around this issue, and I doubt MS will care much as the problem doesn't exist in Vista or Win7. Upgrading XP to SP3 and installing the RDP6.1 client has helped in many cases for me.

If anyone else has something better, feel free to edit it in.

share|improve this answer
    
I'm connecting from an XP SP3 workstation. However, I am using RDP client v.6.0.6001.18000. I find it strange that it would connect and work for a minute but then disconnect me. I'll get the updated client and try again. Thanks. –  JohnyD May 14 '10 at 15:08
    
NM, I have a newer version of the RDP client application than the update in the link you provided. Still not sure why this isn't working. –  JohnyD May 14 '10 at 16:22

Did you enable remote access? On the start menu right click on computer and choose properties. Click on remote settings and (at least to start) ensure that "allow connections from computers running any version of remote desktop" is selected.

share|improve this answer
    
I have enabled remote access. A dialog said that firewall rules had been created. I connected just now and it logged in fine. After about 10 seconds my session is disconnected with the dialog saying, "The computer can't connect to the remote computer. Try connecting again. If the problem continues, contact the owner of the remote computer or your network administrator." So, I can connect... but something is disconnecting me not long afterwards. I have it set to allow connections from all legacy clients. –  JohnyD May 14 '10 at 16:25

100% chris, I also had the same issue some time back SP3 fixed this, have you tried the the second option "allow connections from computers running any version Remote Desktop (Less Secure)" and see if you still get disconnected

share|improve this answer
    
I have done this and I am still getting disconnected. –  JohnyD May 14 '10 at 16:25

based on your 2 updates on this issues, I would advise you to get the latest drivers from Broadcom

http://www.broadcom.com/support/ethernet_nic/downloaddrivers.php

Update the drivers and try each ethernet port on that server, goodluck

share|improve this answer
    
I downloaded the latest Broadcom Nexxtreme II drivers for 64bit win 2008. Windows is telling me that my drivers are up to date. –  JohnyD May 20 '10 at 12:20
up vote 1 down vote accepted

Ok, I now have it working. The 6.1 client did not work for me. The 7.0 client does which can be downloaded here: http://support.microsoft.com/kb/969084/en-us

In addition to this I had to enable two rules in my Inbound firewall: 1) Remote Administration (RPC) 2) Remote Desktop (TCP-In)

Hopefully this will help others. Thanks for all your help.

Edit 1: also, if you want to keep Network Level Authentication for RDP sessions on your 2008 server and you're connecting from your XP SP2/3 workstation than there are some registry changes which you will need to make in order to enable CredSSP. This is from the page: http://support.microsoft.com/kb/951608/

  • Click Start, click Run, type regedit, and then press ENTER.
  • In the navigation pane, locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
  • In the details pane, right-click Security Packages, and then click Modify.
  • In the Value data box, type tspkg. Leave any data that is specific to other SSPs, and then click OK.
  • In the navigation pane, locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders
  • In the details pane, right-click SecurityProviders, and then click Modify.
  • In the Value data box, type credssp.dll. Leave any data that is specific to other SSPs, and then click OK.
  • Exit Registry Editor.
  • Restart the computer.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.