Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a DNS domain and host it on my own server. My desktop PC (Windows XP) is configured to have mydomain.tld as its primary DNS suffix. Now, when the system tries to resolve any domain - stackoverflow.com, for example - it tries with the suffix added first, even if the name has periods in it. In other words, it tries stackoverflow.com.mydomain.tld. before stackoverflow.com..

  1. Is this valid according to DNS standards and common sense?
  2. Is there anything I can do to prevent it, other than removing the prefix completely? (I still want it to be appended to single-component hostnames. Currently I have two prefixes . and mydomain.tld. configured, but it isn't very fast when resolving foohost.)
share|improve this question
    
Something like "stackoverflow.com." (with a trailing period) should be understood to be a fully qualified domain name, meaning it would know not to check stackoverflow.com.mydomain.tld. However, I am not 100% sure that this works on Windows. –  Skyhawk Aug 15 '10 at 23:36
    
@Miles: foo. is understood as a FQDN properly; however, the question is about "FQDNs" as most people type them - without the trailing dot. –  grawity Aug 16 '10 at 9:52
add comment

4 Answers

1: it is valid

2: no. it is there to help you enter server names locally "short" or with partial domains.

2 in particular is the culprit here. This is a stack function checking all default prefixes. Normally this is a technical non-issue as your prefix will end at your server (as it is authoritateive for the internal domains) and thus never hit the internet. Load and traffic make no real difference either.

share|improve this answer
add comment

Speaking anecdotally, I've seen all sorts of weird XP DNS behavior when troubleshooting problems. I've seen exactly what you describe. You'll probably also see resolution requests for 'stackoverflow.com.tld' in there as well. If you have multiple prefixes listed in the Look Order list in TCP/IP properties you'll see it try to resolve those this way as well. I suspect this is a side effect of "Enable NetBIOS names over TCP/IP" and it's attempt to figure out if 'stackoverflow.com' is a NetBIOS name. It then follows standard DNS resolution once NetBIOS resolution fails.

To answer your question, this is (likely) valid NetBIOS name resolution, followed by valid DNS name resolution. Disabling this would require turning off NetBIOS Names over TCP/IP.

share|improve this answer
    
I doubt it. NetBIOS names are resolved using NBT, not DNS, and are limited to 15 bytes. –  grawity May 13 '10 at 19:56
1  
The culprit for causing the 'stackoverflow.com.tld' behavior is an AD feature called DNS Devolution. technet.microsoft.com/en-us/library/ee683928%28WS.10%29.aspx –  Chris Thorpe Aug 15 '10 at 3:54
add comment

Community wiki response based on @Chris Thorpe's original comment referencing Domain Name Devolution:

In HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\DNSClient, change UseDomainNameDevolution from 1 to 0.

share|improve this answer
add comment

Seems to me that NETBIOS over TCP IP is not available in Windows Server 2008,so previous methods of trying first non-FQDN, i.e. NetBIOS names, might be unavailable in Windows Server 2008 domains.

share|improve this answer
    
@whatever-downvoted-my-answer second time, be it bot or human, see my Update1 –  Gennady Vanin Novosibirsk Aug 15 '10 at 11:30
5  
@vg8 - if you continue to post meta discussion here instead of on the meta forum, you'll likely end up suspended. Please feel free to discuss this as much as you like on the META site. –  Kara Marfia Aug 15 '10 at 13:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.