Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a webservice /test/Service1.asmx in the same folder as a page /test/test.aspx.

The page works fine but I get the message bellow for the services in the same location. I know the file is there and the url is correct, and I have added the script module and managed handler as well. If anyone knows what I'm missing here I'd appreciate it

Server Error in '/' Application.


The resource cannot be found. Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly.

Requested URL: /test/Service1.asmx


Version Information: Microsoft .NET Framework Version:2.0.50727.4200; ASP.NET Version:2.0.50727.4016

FAILED REQUEST LOG: ModuleName ManagedPipelineHandler Notification 128 HttpStatus 404 HttpReason Not Found HttpSubStatus 0 ErrorCode 0 ConfigExceptionInfo
Notification EXECUTE_REQUEST_HANDLER ErrorCode The operation completed successfully. (0x0)

share|improve this question
    
Can you run Failed Request Tracing and see at what stage it's failing. –  Vivek Kumbhar May 14 '10 at 14:15
    
yeah guess that would be a good first step, thx –  agilenoob May 14 '10 at 18:35
1  
Can you also check IIS logfile and see the exact error and the status code. I am most interested in sc-status, sc-substatus and sc-win32-status –  Vivek Kumbhar May 14 '10 at 20:03

3 Answers 3

I encountered this issue while doing some test migrations of our intranet applications from IIS6 to 7. I was able to solve the problem by modifying the following section of the Web.config file:

<system.webServer>
   <validation validateIntegratedModeConfiguration="false"/>
   <modules>
      <remove name="ScriptModule"/>
   </modules>
   <handlers>
      <remove name="WebServiceHandlerFactory-Integrated"/>
      <remove name="ScriptHandlerFactory"/>
      <remove name="ScriptHandlerFactoryAppServices"/>
      <remove name="ScriptResource"/>
   </handlers>
</system.webServer>

Change validateIntegratedModeConfiguration to true, and remove the WebServiceHandlerFactory-Integrated from the remove list.

Oddly enough, from memmory ASP.NET adds those lines specifically IIS7. Oh well.

share|improve this answer

did you install ASP.NET Role Service for IIS 7?

share|improve this answer

I had this problem, but for a completely different issue. Make sure you compile your site before deploying it. I had some pages that were compiled and some pages that were not compiled.

It took me so long to figure out because when I tried viewing these pages on the application server (Windows Server 2008), it wouldn't let me view a non secure page (http protocol), because of Internet Explorer's security settings. I only had a binding for port 80 when testing on a browser on the server box. So I couldn't even see the aspx page that was compiled, let alone the aspx pages that were not compiled. A plain HTML page was visible on both boxes however, on the same site--that part was interesting. When I viewed the pages on another machine (running Windows 7) on that network, the compiled aspx page showed up fine because it was compiled. And the non-compiled pages did not.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.